sales@landfx.com
  +1 805-541-1003

Linetype Scale (LTSCALE)

Proper sheet setup requires you to set the correct drawing scale and linetype scale.

 

Linetype scale (LTSCALE) determines the scale and appearance of dashed lines as they appear in your drawing. This setting becomes especially important when you go to plot, since lines that appear dashed in Model Space may appear solid in Paper Space if their LTSCALE isn't exactly correct. Maintaining the integrity of your dashed lines is integral to the accuracy of your drawing. Why? Because CAD standards call for specific lines to be dashed in unique ways in order to distinguish them from other linework. Examples include fences, property lines, utility lines, mainline pipe, and pipe sleeves.

Having trouble getting all your linetypes to look right? Sometimes linetype definitions will load from both Metric and Imperial libraries, making it impossible to get them all to look correct. You can often resolve this issue with our Reload All Linetypes (REAL) command. Running the REAL command will reload all linetypes from the current library. To run the command, type REAL in the Command line and press Enter. Still having issues with making your linetypes look right? Read on.

LTSCALE and PSLTSCALE

In Model Space, you control the linetype scale using the LTSCALE command. This command not only scales the dashes but also the spaces between them. As a result, lines that appear dashed in Model Space (that is, in your working drawing) may appear solid in Paper Space.

 

 

AutoCAD also has a Paper Space linetype scale (PSLTSCALE) command, which, predictably, sets a drawing's linetype scale in Paper Space. It's important to note that PSLTSCALE will only apply to the Layout tab that was open when you set it.

How PSLTSCALE Works

It's important to note that PSLTSCALE is purely an on-off feature. Turning it on (by entering a value of 1 in the Command line after running the PSLTSCALE command) will apply the current viewport scale to the drawing in Paper Space. Turning it off (entering a value of 0 after running the PSLTSCALE command) will take the LTSCALE, which governs linetypes in Model Space, and apply that scale it to linetypes in Paper Space as well. 

The Problem With LTSCALE

Here's the issue: When you have your LTSCALE set to a certain factor in Model Space, the LTSCALE will be different when you enter Paper Space. For example:

 

The drawing shown below is an irrigation design that includes a mainline (the dashed green line).

 

Model Space

Paper Space

This is an issue that CAD users will frequently run into when they simply switch between Model Space and Paper Space in the same drawing. For this reason, as well as several others, we recommend keeping your Layout drawings as separate sheet files.

To get the linetype scale to display properly in Paper Space (not through a viewport), you'll need to set the LTSCALE to 1. However, note that doing so will conflict with the display of linetype scale in Model Space. To combat this issue, you'll need to use one of the methods described below to achieve proper linetype display in both Model Space and your Paper Space sheets.

The Preferred Solution: Xref Your Drawing Into a Separate Sheet File

So what should you do if you run into this LTSCALE issue when navigating between Model and Paper Space? If you have a few minutes to spare, the simplest solution is to Xref your original drawing into a new DWG file. This file will serve as your sheet file. These steps will give you two separate DWG files containing the same design.

Many CAD users shy away from this method because they think it will be time consuming, or they're just plain scared of using Xrefs. Don't fall into this trap; it's actually a very simple method that requires minimal effort. It just takes a little getting used to.

1. In your original drawing (the design file), open our Scale tool to ensure you have the correct scale set. The scale you set will be your Dimscale, which will match your LTSCALE when you are in Model Space in this drawing.

 

 

2. Now open a new drawing. In that new drawing, open the Xref Manager by typing XREF in the Command line and pressing Enter. Xref your original design drawing into the new drawing. In the example below, we are Xrefing the original drawing, My Site Plan, into the new drawing, Drawing 1.

 

 

 

3. Open a Layout tab in the new drawing, and create a Viewport around the design you've Xrefed in. Type PSLTSCALE in the Command line, and type 1 when prompted to Enter a value.

 

The linetype scale of this Viewport (in Paper Space) will now match the linetype scale you've already set in the original drawing (in Model Space). That is, we have an LTSCALE of 1 in Model Space, and a PSLTSCALE of 1 in Paper Space – the default linetype scale setting, and an AutoCAD best practice. We're in great shape!

 

 

4. Save this drawing under a new name, in the same folder where you've saved the original drawing. This drawing is now the sheet file for your site design.

By setting up a sheet file for our original drawing, we are able to view our design in both Model Space (above left) and Paper Space (above right) at the same linetype scale. As a result, our dashed line appears correctly in Paper Space.

Having each sheet on a separate DWG offers the added benefit that drawing cleanup becomes much easier – another reason we recommend it as a CAD best practice.

 

 

Your Original Drawing (Model Space) and Your Sheet File (Paper Space)

You now have two drawings with the correct linetype scales:

  • Your original drawing. You'll make any changes to your design in Model Space in this drawing.
  • The sheet file. This drawing contains an Xref of the original drawing, within your Viewport in Paper Space. 
     

Due to the nature of Xrefs, any changes you make in Model Space in the original drawing will be applied to the Xref in Paper Space in the sheet file. Because of the way you've set up the sheet drawing, the linetype scale will be correct for Model Space in the original drawing, and correct for Paper Space in the sheet drawing.

 

When you want to move between Model Space and Paper Space, you'll simply move between these two drawings. 

 

Switching Between the Two Files

AutoCAD offers a few possible ways to move quickly between drawings:

 

Option 1: File Tabs

Open the AutoCAD Options dialog box by typing Options in the Command line. Select the Display tab, and make sure the Display File Tabs box is checked. Click Apply to save the change.

 

With this setting enabled, you will see a tab at the top of your CAD interface for each drawing you have open. You can easily navigate between these two drawings by clicking the appropriate tab. 

 

Option 2: Switch Windows

You can also jump quickly between drawings by clicking the Switch Windows button on the AutoCAD View ribbon.

 

You can also add this button to your Quick Access Toolbar by right-clicking it and selecting Add to Quick Access Toolbar from the menu that opens.

 

Option 3: Window Menu

Finally, you can switch between drawings by opening the CAD Window menu. All open drawings will appear at the bottom of this menu, with a check mark next to the current drawing. You can jump to a different drawing by selecting it from the menu. 

A Less-Preferable Solution: Single Drawing

This solution will only work on sheets that contain only one Viewport and no details. If you have multiple Viewports, and/or your drawing contains one or more details – and you really don't want to work with Xrefs right now – you will need to use The Least-Preferable Option: Toggling Between Model and Paper Space

Are you trying to adjust the linetype scale in a detail or a schedule? If so, this solution won't work. You'll need to follow the steps for toggling between Model and Paper Space below.

We will always recommend having a separate DWG for each sheet, as described above. Keeping multiple sheets in a single drawing (that is, placing them on Layout tabs rather than Xrefing them in) can lead to any number of problems with your drawing.

 

However, if you must keep your entire design within a single drawing file, you can do so by completing the following instructions:

 

1. Open a Layout tab in your original drawing. Create a Viewport here in Paper Space.

 

 

2. Type PSLTSCALE in the Command line. Type 0 when prompted to Enter a value

A value of 0 turns PSLTSCALE off, which means that the LTSCALE you've set in Model Space will also be applied in Paper Space.

 

3. Repeat steps 1 and 2 for each additional layout tab.

 

 

You should now have a PSLTSCALE of 0 in each Layout tab. Your LTSCALE in Model Space should be the same as the Dimscale you set with our Scale tool. If you haven't changed the LTSCALE in Model Space, it will be correct. 

 

Keeping all your sheets in a single drawing may seem like a much simpler process than creating a new DWG for each sheet – and it is ... in the short term. However, it can cause problems of a much greater complexity down the road. You'll keep your future self a lot happier if you make it a habit to create separate sheet files.

The Least Preferable Option: Toggling Between Paper and Model Space

The following solution is only a good idea if you're up against a deadline, need to plot NOW, and aren't feeling confident to set up Xrefs at the moment.

 

If you're facing a deadline and simply aren't ready to work with Xrefs right now, we can offer another (albeit temporary) solution: manually toggling between the appropriate scales each time you switch between Model Space and Paper Space. Remember: We don't recommend this option as a long-term solution; it's just a stopgap for dealing with the LTSCALE issue temporarily so you can make your deadline.

 

Going Into Paper Space and Plotting

1. Once you are ready to plot, open a Layout tab and type PSLTSCALE in the Command line.

 

 

2. Type 1.0 when prompted to Enter a value. This command will set your Paper Space linetype scale to "on," which will scale your drawing correctly to Paper Space.

 

 

3. You may need to type REA (or RegenAll) in the Command line to regenerate your drawing in order to apply the linetype scaling correctly.

 

You can now plot.

 

Keep in mind that PSLTSCALE will only apply to the Layout tab you had open when you set it.

 

Going Back Into Model Space

If you need to go back to Model Space, you will then need to correct your LTSCALE.

 

 

Open Model Space, then type LTSCALE in the Command line.

 

 

When prompted to Enter a value, type the correct Dimscale of the drawing (that is, your intended scale).

 

The Dimscale will depend on both your scale and units. For example:

  • Scale is set to 1 inch = 20 feet, and units are set to Architectural Inches, as in our example above: The Dimscale will be 240 (for 240 inches).
  • Scale is set to 1 inch = 20 feet, and units are set to Decimal Feet: The Dimscale will be 20, for 20 feet.
  • Scale is set to 1 inch = 100 feet, and units are set to Architectural Inches: The Dimscale will be 1200 (for 1,200 inches).
  • Scale is set to 1 inch = 100 feet, and units are set to Decimal Feet: The Dimscale will be 100, for 100 feet.

And so on.

 

The drawing will now appear correctly in Model Space. If you need to plot now, set you LTSCALE back to 1 in Model Space, then open Paper Space and plot.

 

You can continue to toggle between linetype scales in this way each time you go between Model Space and Paper Space. So when you go back into Paper Space, you'll need to follow the Paper Space and Plotting steps linked above.

We recommend Xrefing your plan, setting up your Layout sheet in that separate file, and then Xrefing it back in as a sheet. This practice will prevent several problems in the future. If you don't have the time to learn this preferable method today, you'll thank yourself if you take the time to learn it tomorrow.

Troubleshooting

Issue: After fixing the LTSCALE and PSLTSCALE as described above, you're still seeing solid lines in your drawings where you should be seeing dashed lines

Last modified on Thursday, 06 June 2019 14:20
Print

Log in to landfx.com:

Username:

Password: