sales@landfx.com
  +1 805-541-1003

Working With Drawing Templates (DWTs)

Setting up a CAD drawing template ensures that when you open a fresh CAD drawing, you are opening a clean file set to the correct units. A template – a completely clean drawing with no layer settings – is saved in your CAD settings as a DWT file. You should create a template for each unit setting you plan on using. For example:

  • If you work in Imperial units, create one template for Architectural or Engineering inches, and one for decimal feet.
  • If you work in Metric units, create one template for decimal millimeters and one for decimal meters.

A drawing template is not the same as a Land F/X project template. Learn more about Land F/X project templates.

Opening one of the AutoCAD Templates

Your AutoCAD installation comes with several template files, all of which are available from the Templates menu on the Get Started screen that pops up when you open AutoCAD. Depending on your system of measurement, open one of the following default templates to create your template:

  • Imperial: Open the template acad.dwt.
  • Metric: Open the template acadiso.dwt.

 

To enable the Get Started screen, set the STARTUP system variable to 2 and the STARTMODE system variable to 1:

  • Type STARTUP in the AutoCAD Command line and press Enter. When prompted to set a value, type 2 and press Enter.
  • Type STARTMODE in the AutoCAD Command line and press Enter. When prompted to set a value, type 1 and press Enter.

If you anticipate that you'll use both Imperial and Metric measuring systems, you'll need to create a separate template from each of these two files.

 

Complete the steps below from within the template file(s) you open from this menu.

Creating Your Templates

Repeat the following steps for each unit setting you plan to use in your drawings.

 

 

Setting the Drawing Units

Open a fresh CAD drawing. Type Units in the Command line, and press Enter.

 

The Drawing Units dialog box will open. Set the Type and Insertion Scale menus to a unit setting you plan to use.

 

If you work in Imperial units, you'll need to make one template for architectural or engineering inches, and one for decimal feet.

 

 

 

Metric units are always decimal. If you work in Metric units, you'll need to make one template in decimal millimeters and one in decimal meters. 

 

 

 

Setting the PSLTSCALE and LTSCALE to 1

Open one of the Layout tabs. You should now be in Paper Space.

Setting the Paper Space Linetype Scale (PSLTSCALE) and Linetype Scale (LTSCALE) both to 1 will ensure that your linetypes appear correctly in both Model Space and Paper Space. For more information, see our LTSCALE documentation page.

 

 

Setting the Paper Space Linetype Scale (PSLTSCALE) to 1

Type PSLTSCALE in the Command line, and press Enter.

 

When prompted to set a value, type 1 and press Enter. Your Paper Space linetype scale should now be set to 1.

 

 

Setting the Model Space Linetype Scale (LTSCALE) to 1

Type LTSCALE in the Command line, and press Enter.

 

When prompted to set a value, type 1 and press Enter. Your Model Space linetype scale should now be set to 1.

 

 

Setting UCSFOLLOW to 0

Setting the system variable UCSFOLLOW to 0 will ensure that you can continue to view your drawing correctly in plan view if you create a User Coordinate System (UCS).

 

Still in Paper Space, type UCSFOLLOW in the Command line. When prompted to set a value, type 0 and press Enter.

 

 

 

That's it. Your template is complete, and you're ready to save it.

 

 

Important: Do Not Open or Create a Land F/X Project When Creating Your Drawing Template

Your drawing template should not have a Land F/X project associated with it. When creating your drawing template, do not create or add a Land F/X project. If you do, that same project will be automatically assigned to each new drawing you create, which can potentially cause any number of issues should you forget to assign it with a new project. Leave your template without a project, then create a new project each time you start a new drawing.

Already created a project with your template open? Follow our steps to disassociate a Land F/X project from an AutoCAD drawing template

A drawing template is not the same as a Land F/X project template. Learn more about Land F/X project templates.

Saving Your Templates

When you save your drawing templates, you'll save each of them to two separate locations:

  • A backup location of your choice (usually a folder on your computer)
  • The Template folder within your AutoCAD folder path

 

 

Saving a Template to a Backup Location

 

 

Select Save As from the AutoCAD File menu, or press the CTRL + SHIFT + S keys.

 

 

 

Browse to the location of your choice, and save your template.

 

 

We recommend maintaining a Templates folder to store all your templates.

If your office uses a common server, your templates folder should be saved on that server, which will ensure that:

  • All office CAD installations can reference it.
  • Any future changes to template files will instantly update for all users.

 

 

Save your template as an AutoCAD Drawing Template (.dwt).

 

 

 

Redirect Your CAD Options Away from the Default Template Location

Now that you've saved your template, you'll need to inform CAD of that location by pointing the CAD Options away from that location.

 

 

 

Type Options in the Command line and press Enter to open the Options dialog box.

 

 

Select the Files tab.

 

 

Click the plus (+) sign next to the Template Settings entry.

 

 

 

 

The Template Settings category will expand.

 

 

Expand the Drawing Template File Location category by clicking the plus (+) sign.

 

 

Select the file in this category, and click Browse.

 

 

 

Browse to the folder you selected in the Backup Location steps above, and click OK.

 

 

 

 

 

The location you selected will now be listed under the Drawing Template File Location.

 

 

 

Click Apply to save your selection.

 

 

 

Saving a Template to the AutoCAD Folder Path

 

Select Save As from the AutoCAD File menu, or press the CTRL + SHIFT + S keys.

 

 

 

Select the AutoCAD Drawing Template (.dwt) option from the Files of Type menu.

 

 

You'll be brought automatically to the Template folder within the AutoCAD folder path.

 

 

Save your template to this location.

 

 

 

Setting a Template as the Default Template File for QNEW

When you want to open a template, the QNEW command opens a template you've selected. To select the template that will open when you run the QNEW command, you'll need to add it to the Files tab in the Options dialog box. Complete the following steps for the template you plan to use most often.

 

Type Options in the Command line and press Enter to open the Options dialog box.

 

 

Select the Files tab.

 

 

Click the plus (+) sign next to the Template Settings entry.

 

 

 

The Template Settings category will expand.

 

 

Expand the Default Template File Name for QNEW by clicking the plus (+) sign.

 

 

Select the file in this category (you might simply see the word None here). Click Browse.

 

 

 

You'll be brought to the Template folder, where you saved your template.

 

 

Click your template to highlight it, then click Open.

 

 

 

 

 

Your template will now be the default template for the QNEW command.

 

 

 

Click Apply to save your changes.

Opening Your Templates

Opening a QNEW Template

To open the template you saved as the QNEW default, type QNEW in the Command line. Your template will open.

 

Immediately save your template as a CAD drawing file (DWG).

 

Opening a Template from the File Menu

 

Select Open from the CAD File menu, or press the CTRL + O keys.

 

 

 

In the Select File dialog box, navigate to the template you want to use.

 

 

Select it, and click Open.

 

 

 

Immediately save your template immediately as a CAD drawing file (DWG).

 

 

Opening Your Template from the AutoCAD Get Started Screen

You can also access your templates from the Templates menu on the AutoCAD Get Started screen.

 

 

To enable the Get Started screen, set the STARTUP system variable to 2 and the STARTMODE system variable to 1:

  • Type STARTUP in the AutoCAD Command line and press Enter. When prompted to set a value, type 2 and press Enter.
  • Type STARTMODE in the AutoCAD Command line and press Enter. When prompted to set a value, type 1 and press Enter.

 

Once you save your templates, you'll be able to open them from the menu pictured below.

 

Saving an Open Template as a CAD Drawing File (DWG)

When you first open a template to use as a basis for a drawing, make sure you immediately save it as a CAD drawing.

 

 

Select Save As from the File menu.

 

 

 

 

 

 

Navigate to the location where you want to save the drawing.

 

 

 

Give the drawing a name, and save it as a DWG.

 

 

 

In most cases, you'll want to select the most recent DWG format available (example: AutoCAD 2013 Drawing).

Last modified on Wednesday, 12 September 2018 09:55
Print

Log in to landfx.com:

Username:

Password: