CAD Options Settings

CAD Options Settings

The CAD Options dialog box is essentially your one-stop control panel for your general settings. For CAD to work best with Land F/X software, we have developed some specific recommendations for setting your preferences in this dialog box. This section covers our recommendations for the settings included on each tab of the Options dialog box, from left to right. Take the time to configure your settings, and create an optimal experience designing in CAD while using our software.

CAD Options Overview

Open the Options dialog box:

 

 

Manage ribbon, Options button

 

Manage ribbon, Options button

 

 

 

type Options in the Command line

 

 

 

 

right-click in the Command line and select Options from the menu

Tools menu

 

Tools pull-down menu

Files Tab

Files tab, Printer Support Search Path

The Printer Support Search Path will store your Plotter Configuration (PC3) Files.

For more information on PC3 files, see our Create Plotter Configuration Files (PC3) documentation page.

 

 

 

The Plot Style Table Search Path will be the location of your CTB Plot Styles.

 

 

 

Click Add to add a new CTB plot style.

For more information on CTB Plot Styles, see our About New CTB Plot Styles articl.

Files tab, Plot Style Table Search Path

 

 

 

Files tab, Automatic Save File Location

Your automatic backups will be saved to the Automatic Save File Location.

 

 

 

Click Browse to set a new automatic backup location.

Display Tab

The Color Scheme menu options in the Display tab affect the appearance of your ribbons and toolbars.

 

 

 

Display tab, Light theme option

Select Light to have light-colored ribbons and toolbars.

Display tab, Dark theme option

Select Dark to have dark-colored ribbons and toolbars.

 

 

 

Examples:

 

F/X Planting ribbon, Light theme

 

F/X Planting ribbon, Light theme selected

 

 

F/X Planting ribbon, Dark theme

 

F/X Planting ribbon, Dark theme selected

Planting toolbar, Light theme

Planting toolbar, Light option selected

 

 

 

 

Planting toolbar, Dark theme

Planting toolbar, Dark option selected

 

 

 

The Display tab includes an option to Display scroll bars in drawing window.

 

 

Select the option that suits your preference.

Display tab, Display scroll bars in drawing window option

 

 

 

Display tab, option to displau Model and Layout tabs

 

 

 

 

 

 

The Display tab also includes the option to display your Model and Layout tabs.

 

 

 

Selecting this option will display your Model and Layout tabs, as pictured below.

 

 

 

With your Model and Layout tabs displayed, you'll be able to switch quickly between Model Space and Paper Space.

Model and Layout tabs displayed

 

 

 

Display tab, Xref Display option

The Xref Display setting (under Fade Control) determines how dark the linework from your Xrefs will display.

 

 

This setting works on a scale of 0 (no fading, or full darkness of linework) to 100 (transparent liework).

 

 

You can type your preferred value in the text field (example: 50) or use the slide.

Open and Save Tab

Open and Save tab, recommended settings

The Open and Save tab includes a few especially important settings for optimal Land F/X use under the OpjectARX Applications heading, as shown below.

 

  • Demand load ObjectARX apps: Select Command invoke from the menu.

 

  • Proxy images for custom objects: Select Do not show proxy graphics from the menu.

 

  • Show Proxy Information dialog box: Check this box.

 

 

  • We also recommend leaving the Display digital signature information option unchecked.

The Open and Save tab also includes options to control the number of recently opened drawing files in both the CAD File menu and the Recent Documents list on the home screen, which you see when you have CAD open but don't have a drawing open. See our Recent Documents List documentation page for more information.

Plot and Publish Tab

 

 

 

Under the Plot and Publish tab, we recommend unchecking both the Plotting and Publishing boxes under Enable Background plot when:

Plot and Publish tab, recommended settings

System Tab

System tab, Security options

Under the System tab, click the Security Options button to configure your security settings.

In previous versions, this utility was known as Executable File Settings.

 

 

 

The Security Options dialog box will open. We recommend the following settings:

 

 

1. Use the slide to set the Security Level to Medium.

 

 

 

2. When searching for executable files: Select Exclude the Start In or drawing folders.

 

 

 

3. Choose the method to load acad.lsp.: Select Load acad.lsp once at the start of the session.

 

 

Click OK to save your changes.

Security Options dialog box, recommended settings

User Preferences Tab

The User Preferences tab offers a number of options for customizing your interface with CAD.

 

 

 

We recommend taking a look at the Right-Click Customization settings.

User Preferences tab, Right-Click Customization settings

 

 

 

The Right-Click Customization dialog box provides several options for what happens in CAD when you right-click with your mouse.

 

 

 

Right-Click Customization, recommended settings

1. Default Mode: We recommend selecting Repeat Last Command. Under this setting, right-clicking when no objects are selected will repeat the most recent command you have executed in CAD.

 

2. Edit Mode: We recommend selecting Shortcut Menu. Under this setting, right-clicking when one or more objects are selected will cause a shortcut menu to appear.

 

3. Command Mode: We recommend selecting ENTER.

Many of our commands have a default action that you can specify by right-clicking – such as right-clicking to end a command, select the defaut destination, etc. The ENTER option minimizes the number of clicks for these purposes. (The other two options will result in a minimum of two clicks, which can add up quickly!)

 

4. Click Apply & Close to save your changes.

 

Shortcut menus in drawing area

 

This option is more of an indicator than a setting. To allow this option to remain checked, you'll need to select the Shortcut option for at least one of the three Modes in the Right-Click Customization settings. We recommend setting the Edit Mode option to Shortcut Menu, as shown above.

 

 

 

User Preferences tab, Insertion Scale recommended setting

We also recommend setting both Insertion Scale menus to Unspecified - Unitless.

 

 

This setting will prevent scaling issues with files you Xref into your drawing.

Drafting Tab

 

 

 

We don't have any specific recommendations for the Drafting tab. You can review the available options and make any adjustments according to your preferences.

Drafting tab options

3D Modeling Tab

We offer the following recommendations under the 3D Modeling tab:

 

 

 

3D Miodeling tab, recommended settings

 

 

 

 

 

 

 

 

 

 

 

 

Display the Viewcube: Uncheck both options.

 

 

 


Display the Viewport Controls: Uncheck this option.

Selection Tab

We offer the following recommendations under the Selection tab:

 

 

 

 

 

 

 

 

 

 

Selection modes: Check the box next to Noun/verb selection.

 

 

 

 

 

 

 

Selection Preview: Check the box next to When no command is active.

Selection tab, recommended settings

 

 

 

Selection tab, Visual Effects Settings button

In addition, we recommend taking a look at the Visual Effects Settings.

 

 

 

Clicking this button opens the Visual Effect Settings dialog box.

 

 

 

Of particular significance is the list of Selection Preview Filter settings. Here, you can select which objects are excluded from a selection preview – the highlighting of objects in your drawing when you hover over them.

 

 

 

 

A Selection Preview provides a visual indication of which objects you're about to select in your drawing by clicking with your mouse.

 

 

 

 

Your settings for the majority of these options will depend on your personal preferences. However, we recommend checking the box next to Hatches. This setting will exclude hatches from unnecessary selection previews.

Selection Preview Filter settings

Profiles Tab

Profiles tab settings

Once you've configured your Options settings, you can save them as a profile using the options in the Profiles tab.

 

 

You can even save several different settings profiles in the Available Profiles list.

 

 

In this way, you can switch between settings quickly for projects with different needs, different users on your computer, etc.

 

 

 

Clicking Export allows you to export your settings as an ARG file.

Profiles tab, exporting settings

 

 

 

Setting a profile to current

To apply one of your Options settings profiles to your current work, highlight the profile in the list and click Set Current.

Once you've created a profile, make sure to back it up as described below. For more information on profiles, see our AutoCAD Profile documentation.

 

 

 

Delete a Profile

 

 

 

 

To delete a profile, highlight it and click Delete.

Deleting a profile

Backing Up Your Settings

As with all files containing your CAD settings, it's a good idea to back up your AutoCAD profiles to a central location you can locate and access easily. We recommend creating a CAD Standards folder and saving it in your LandFX/Admin folder. You can then copy your profile (ARG file) to this folder periodically.

For more information, see our CAD Standards Folder article.

Related Webinars

  • Getting to Know Your CAD Interface: Take a tour through your CAD interface, covering the basics of the various tool panels and ribbons, options, setup preferences, and more. You'll then learn how to save all your preferred settings into a profile. (56 min)

Troubleshooting

Issue: "The directory specified for action macro files must exist and have read/write permission" error when attempting to close the Options dialog box

Last modified on Wednesday, 30 March 2022 09:54

Log in to landfx.com:

Username:

Password: