Planting F/X Plugin for SketchUp: One Tool Is Not Working, but Other Tools Are Working
Issue
While using our Planting F/X Plugin for SketchUp, you attempted to click a tool and its corresponding dialog box doesn't open. Other tools' dialog boxes are opening just fine.
For example, you may have clicked the Import Layer tool but its dialog box doesn't show up, even though you're able to use other tools in the plugin.
Cause
The dialog box is likely popping up off screen because you are either using an external monitor or changing monitor resolution, which is causing the dialog box off in space at the old orientation.
Solution
You'll need to look into the JSON file where these dialog box settings are stored and reset them to allow for a normal position.
1. Close Sketchup and navigate to the location C:\Users\username\AppData\Local\SketchUp\SketchUp 20XX\SketchUp (where 20XX is your year version of SketchUp).
Double-click the file PrivatePreferences.json to open it in a text application such as Notepad.
2. Press the CTRL + F keys to find text. Search for lfx.
3. Navigate through your findings until you get to the WebCommonDialog_lfx section. Locate subsection for the dialog box causing your issue. (In our example, we're looking for the _importlayer section, which corresponds with the Import Layer dialog box.
4. Look through each justification to see whether any of the numbers stand out.
A number with a negative value or an extremely different value from the values of the other dialog box sets might be the culprit.
Correct the problematic number. For example, if you see a negative number, make it positive but with the same value. In this example, we'd change -735 to 735.
5. Save the changes to the file.
6. Open SketchUp and try opening the dialog box that wasn't working before. It should now open properly.