Land F/X
  • Portal
  • Products
    • Design F/X
    • Planting F/X
    • Irrigation F/X
    • F/X CAD
    • Plugin for Revit®
    • Plugin for SketchUp®
    • Lighting
    • Plugin for Rhino®
    • Manufacturer Connection
    • Academic
  • Support
  • Videos
  • Who We Are
  • Trial
  • Purchase
Land F/X
  • Portal
    • Dashboard
    • Account
    • Licenses
    • Data
    • Support
  • Products
    • Design F/X
      • Product
      • Features
      • Trial
      • Purchase
    • Planting F/X
      • Product
      • Features
      • Trial
      • Purchase
    • Irrigation F/X
      • Product
      • Features
      • Trial
      • Purchase
    • F/X CAD
    • Plugin for Revit®
    • Plugin for SketchUp®
    • Plugin for Rhino®
    • Site & Hardscape
    • Lighting
    • Manufacturer Connection
    • Academic
    • Purchase
  • Support
    • Knowledge Base
    • Documentation
    • Submit Ticket
    • Updates
    • Forum
    • Install
    • Remote Assistance
  • Videos
    • Power Tips
    • Webinars
  • Who We Are
    • Contact Us
    • Careers
    • Gallery
    • News
  1. Knowledge Base
  2. 3D Rendering
  3. Revit Issues & Info
  4. Knowledge Base
  5. 3D Rendering
  6. Adding, Placing & Editing Plants in Revit®
  7. You Are Unable to See the Planting F/X for Revit® Plugin Plant Family Library

External Tool Failure (Revit Add-in) Revit Cannot Run the External Application "Land F/X", System.IO.FileLoadException (Using One of Our Revit® Plugins)

Issue

 

You saw one of the following error messages after installing the Planting F/X for Revit Plugin and opening Revit:

External tool failure

Revit cannot run the external application "Land F/X". Contact the provider for assistance. Information they provided to Revit about their identity: Land F/X, www.landfx.com

System.IO.FileLoadException

Could not load file or assembly

 

or

 

Could not load file or assembly LandFXRevitAddin.dll, or one of dependencies. Operation is not supported. Exception from HRESULT 0x80131515.

Revit cannot run the external application 'Land F/X'

 

 

 

Cause

You've encountered a default Revit error message, which is an indication that we still need to either fix or assign a specific error message to the issue you're experiencing. (This can happen as we work on the beta version.)

 

 

 

Solution

1. Drop down the Show Details option in the error message, and take a screenshot of the result. This section will likely contain key information for us to replicate and fix this error message.

 

Dropping down the Show Details option in the error message

 

 

2. Send us a technical support ticket that includes

  • Your screenshot of the expanded error message
  • Your file

  • Your Land F/X project data
  • A step-by-step description of what you were trying to do when you encountered the error

 

We’ll use all this information to replicate the error so we can fix it.

 

Revit® is a restricted trademark of Autodesk®.

Contact

  • Land F/X
  • PMB 351
    3940 Broad St. STE 7
    San Luis Obispo, CA 93401
  • +1 805-541-1003
Email Logo Facebook Logo Instagram Logo LinkedIn Logo
Land F/X Logo

Our software tailors AutoCAD®, Revit®, and SketchUp® to the needs of landscape architects, irrigation designers, and other professionals. We automate your most tedious tasks and ensure accuracy, giving you more time to design.

  • Portal
  • Products
  • Support
  • Videos
  • Who We Are