Library in the Planting F/X for Revit® Plugin Is Suddenly Not Set After Updating
Updated on: March 13, 2026
Issue
You updated our Planting F/X for Revit Plugin to version 2.0.44 or later, and despite having using the plugin before, you noticed that the library is suddenly blank.
Trying to use any tool opens the General Preferences dialog box, showing the blank library field.

Cause
We changed the library setup process to require only linking to a parent folder once, and then the plugin will create the necessary year folders. This update will make it easier to use Planting F/X across any version of Revit, while also reducing confusion on where to set the library for new users. We plan to continue to improve this process, and this is the first step.
Solution
Browse to the folder above the year folder that you previously choose. We suggest something like
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