Error: The Following Items Failed to Import (Importing with SketchUp 3D Connection)
Issue
You tried to import plants (trees and shrubs), site amenities, or lighting objects via the 3D Connection in our plugin for SketchUp, but the import didn't go through and you saw the following error message:
The following items failed to import: (followed by a list of plants, site, or lighting equipment).

You'll have also seen the following message first:
SketchUp components could not be found for 1 of these items. Proceed anyway? Items missing a SketchUp component will not be imported (Cancel/OK)
The error box will then show those items with missing components.

Cause
These objects have most likely not been assigned to a SketchUp symbol component. The plugin cannot place 3D Connection imports if they don't have a SketchUp component assigned, and will instead list them here to let you know which ones still need a symbol assignment.
In the example shown here, the tree ACA ACM shows an empty component symbol assignment in the import dialog box.
In the same example, ACA ACM does not show a component symbol assignment in the symbol preview section of the Plant Manager in SketchUp.
Site objects with the same issue will look similar in the Site Manager.

Solutions and Troubleshooting
To address the issue, start the import process again. This time, before clicking the Import button, click the empty symbol boxes above each item to be imported and verify that each item has a symbol assignment.
You can complete this process by editing a plant or site amenity and assigning a component using our Object Info tool.

Still having issues?
If the SketchUp component assignment keeps unassigning, you might be using Local Lata in AutoCAD, F/X CAD, or Civil 3D. Those plugins must be set to Cloud Data for the best experience coordinating with our plugins for SketchUp, Rhino, or Revit.
If you're still having trouble, follow our steps to open the Developer Ruby Console in SketchUp first, then try importing again. Then open a technical support ticket, explain your troubleshooting steps so far, and copy in the contents of the Ruby Console reporting.