Unable to Register for a Land F/X Webinar
Issue
You're unable to register for one of our webinar presentations.
For example, you might have reached the registration screen and it seems to be stuck loading.
Cause
We've seen this issue with users trying to register for webinars while using the Internet Explorer browser. The Zoom Web Client, the service we use forwebinar registration, does not play well with Intrnet Explorer.
Solution
Try registering for the webinar using a different browser, such as Firefox, Google Chrome, or Microsoft Edge.
For more information on the Zoom Web Client and browser support, see the Zoom Help Center page.