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  1. Knowledge Base
  2. Admin
  3. Menus & Ribbons
  4. Land F/X Menus and Ribbons Disappear or Unload (Running a New F/X Workstation Installer)

Question Marks (?) / Damaged or Missing Icons Appearing in Place of Land F/X Tool Icons in Land F/X Ribbons or Quick Access Toolbar

Issue

You see question marks (?), damaged icons, or missing icons instead of your Land F/X tool icons on your Land F/X ribbons ...

 

 

Question marks in place of Land F/X tool icons on ribbons

 

 

... or on your Quick Access Toolbar, as pictured below.

 

Question marks in place of Land F/X tool icons on Quick Access Toolbar

Important: Do not uninstall Land F/X when you encounter this issue! Uninstalling will lead to a whole new set of issues. If you experience this issue, please follow the steps outlined below.

 

 

Cause

Your Land F/X Workstation installation has become corrupted.

 

 

Solution

Step 1: Uninstall the Land F/X Workstation component.

Follow our steps to uninstall Land F/X Workstation .

 

 

 

Step 2: Run our latest F/X Workstation installer.

Follow our steps to download our latest Land F/X Workstation installer (setup_FXWorkstation) and run it from your LandFX folder.

 

After running the installer from your LandFX folder, you may need to load your Land F/X menus.

 

You should now be able to see your Land F/X tool icons within your ribbons.

 

AutoCAD tool icons visible on ribbons

 

AutoCAD ribbons (Light theme)

 

 

Land F/X tool icons visible on ribbons

 

Land F/X ribbons (Light theme)

 

Still seeing question marks instead of your icons? Move on to the next step.

 

 

Step 3 (if necessary): Delete any versions of the file landfx.cuix in incorrect locations.

Open Windows Explorer, and type landfx.cuix into the search box.

 

Searching for landfx.cuix in Windows Explorer

 

 

 

The file landfx.cuix should only be located within the two following paths:

• C:\Users\your username*\Appdata\Roaming\Autodesk\AutoCAD20xx**\Rxx.x**\enu\Support

* Your computer username

** These exact folder names will vary depending on your year version of CAD

 

• C:\Program Files\Autodesk\ApplicationPlugins\landfx.bundle\Contents\Resources\20xx**

** This exact folder name will vary depending on your year version of CAD

Important: You'll need to have hidden files and folders visible to navigate to these folder paths.

landfx.cuix in folder path 1

 

landfx.cuix in folder path 2

 

 

Do you see any versions of the file landfx.cuix that are NOT within the two folder paths shown above?

 

If so, delete these files. Do not delete the landfx.cuix files from the folder paths shown above.

 

Don't see the landfx.cuix file in the path C:\Program Files\Autodesk\ApplicationPlugins\landfx.bundle\Contents\Resources/20**? Here's what to do.

 

If you don't see a landfx.cuix file in the folder path pictured below, you'll need to add it back to the Support File Search Path.

 

landfx.cuix in folder path

 

 

 

To access the Support File Search Path, open the Options dialog box:

 

 

Manage ribbon, Options button

Manage ribbon, Options button

 

 

 

type Options in the Command line

 

 

 

 

right-click in the Command line and select Options from the menu

Tools menu

Tools pull-down menu

 

 

 

Select the Files tab.

 

 

Click the plus (+) sign next to the Support File Search Path entry.

Expanding the Support File Search Path

 

 

 

The Support File Search Path will expand, revealing the folders listed in the path.

 

Look for the path C:\Program Files\Autodesk\ApplicationPlugins\landfx.bundle\Contents\Resources\20xx*.

Where >*20xx is your year version of CAD

 

Don't see this path in the Support File Search Path? Add it back:

1. Click Add.

2. Click Browse, and browse to the path listed above.

3. Click Apply to save the change.

 

landfx.cuix in folder path

 

 

 

Restart CAD.

 

Still seeing question marks in place of the ribbon icons? If so, open the Options dialog box again, and check for the path C:\Program Files\Autodesk\ApplicationPlugins\landfx.bundle\Contents\Resources\20xx* in the Support File Search Path.

 

If this path is no longer in the Support File Search Path, a custom LISP routine may be setting your Support Paths at startup, you'll need to add the path to your routine.

 

After addong the path to your routine, restart CAD again. If the path is still missing from the Support File Search Paths, check for any other CAD plugins loading and remove them. Then restart CAD and test again.

 

If the path is still missing after you've restarted CAD and made the change described above, create a new Windows user profile and check whether the issue persists under that account as well.

 

Is the issue resolved now?

  • Yes: Migrate your (or the CAD user's) existing data over to the new profile. Here's how to do that.
  • No: Move on to the next step in this article.

 

 Close

 

 

Still don't see your icons, or receiving an error message? Move on the next step.

 

 

Step 4 (if necessary): Install the F/X Workstation component manually.

If you're still seeing question marks in place of your icons, or receiving an error message, complete our manual Workstation installation instructions.

If you still don't see your icons, or if you're receiving an error message at this point, move on to the next step.

 

 

Step 5 (if necessary): Delete the CUIX and MNR files.

Open the following folder:

C:\Users\your username*\Appdata\Roaming\Autodesk\AutoCAD20xx**\Rxx.x**\enu\Support

* Your computer username

** These exact folder names will vary depending on your installation of CAD

Important: You'll need to have hidden files and folders visible to navigate to this folder path.

 

Within that folder, delete the following files:

  • landfx.cuix
  • landfx.mnr
  • landfx_light.mnr

 

landfx.cuix, landfx.mnr, and landfx_light.mnr files

 

 

 

This file will be re-created when you reopen AutoCAD.

Still not seeing the icons on the Quick Access Toolbar? Move on to the next step.

 

 

Step 6 (if necessary): Delete and re-add icons on the Quick Access Toolbar.

 

 

6A. Right-click one of the question marks on the Quick Access Toolbar.

Right-clicking a question mark on Quick Access Toolbar

 

 

 

_Remove from Quick Access Toolbar menu option

6B. Select _Remove from Quick Access Toolbar from the menu that opens.

Repeat steps 6A. and 6B. for each question mark icon on your Quick Access Toolbar.

 

 

 

6C. Right-click any icon on one of the ribbons that you want to add to your Quick Access Toolbar.
Right-clicking a ribbon icon

 

 

 

Add to Quick Access Toolbar menu option
6D. Select Add to Quick Access Toolbar from the menu that opens.

Repeat Steps 4 and 5 for each icon you want to add back to the Quick Access Toolbar.

 

 

The Quick Access Toolbar should now include each tool icon you added (example: Projects).
Tools now included in Quick Access Toolbar

Still not seeing the icons? Move on to the next step.

 

 

Step 7 (if necessary): Reset CAD to the default settings.

If you tried all previous steps and you're still not seeing the icons, you can resolve the issue by resetting CAD to the default settings.

Contact

  • Land F/X
  • PMB 351
    3940 Broad St. STE 7
    San Luis Obispo, CA 93401
  • +1 805-541-1003
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