sales@landfx.com
  +1 805-541-1003

Automation Error

Issue

You received an Automation Error message when using one of our plugins with AutoCAD or F/X CAD.

 

Several different Automation Error messages are possible. We log each one on this page when we see it.

 

Here are the Automation Error messages we've seen so far:

  • Error: 'Automation Error. Description was not provided.' – when placing or sizing irrigation heads
  • Error: 'Automation Error. Invalid argument ... in SetBitmap' – when placing or sizing irrigation heads
  • Error: 'Automation Error: Problem in loading application' – when opening one of the Land F/X tools
  • Error: 'Automation Error: No database' – can occur when opening CAD or attempting to use one of our tools
  • Error connecting to LandFX database: Automation Error – when attempting to use one of our tools
  • Error: 'Automation Error: Error decrypting data' – when editing a detail
  • Automation Error. Null object ID – when working with block or detail files, such as updating details
  • Error: 'Automation Error: On locked layer' – when placing a schedule or block
  • Error: 'Automation Error: Access is denied' (possibly accompanied by a 404 File not found error) – when placing a block or updating Land F/X
  • Error: 'Automation Error: An invalid character was found in text content'
  • Error: 'Automation Error: The system cannot locate the resource specified'

 

Cause

A core architecture within Windows operating systems is the ability to call other programs for common tasks. In regards to this error, this process is called “automation.”

 

An error in the automation process can mean anything from a legitimate cause (a common library was unable to open a file) to a bug (the variable name for the task was misspelled, or mistakenly released).

 

The important thing to note is that the fact that the error is an “Automation Error” really doesn’t mean much of anything on its own. For all practical purposes, that phrase is irrelevant, and the “actual” error message is the text that follows the text "Automation Error."

 

Solution

The cause and solution of this error will depend on the text that accompanies Automation Error in the message:

 

 

Error: 'Automation Error. Description was not provided.'

• Error: 'Automation Error. Invalid argument ... in SetBitmap'

You may have received one of these Automation Error messages when placing or sizing irrigation heads.

 

With either of these functions, the system attempts to set the legacy toolbar image to the radius of the spray head selected. If you receive an Automation Error when doing this, it's because you are using an extremely old version of one of our toolbars. As a result, the common Windows library for dealing with toolbars is unable to load the revised bitmap image.

 

If you've received either of these Automation Error messages, please follow our steps to download and run the latest Land F/X Workstation installer.

We also recommend that you start using our ribbons rather than the toolbars.

 

 

• Error: 'Automation Error: Problem in loading application'

• Error: 'Automation Error: No database'

You may see one of these errors when opening one of our tools or when opening AutoCAD or F/X CAD.

 

A Problem in loading application error means that the library itself cannot be loaded. A No database error means that there's no object database at all. Either way, the only solution is to reinstall AutoCAD or F/X CAD.

 

 

• Error connecting to LandFX database: Automation Error

You might see this error when attempting to use one of our tools. The cause will depend on whether your office has Local Data or Cloud Data, although in either case you'll need to send us a technical support ticket.

Don't know whether your office has Local or Cloud Data? Ask your IT administrator.

 

  • If your office has Local Data and you received this error, you are likely experiencing a problem with your MySQL database server.

 

  • If you have Cloud Data, you may also receive the following error message: Access denied for user ‘ODBC’@‘XXX.XX.XX.XXX’ (where XXX.XX.XX.XXX represents your Internet IP address). In this case, your install.xml file has been mistakenly switched to Local Data.

 

In either case, please send us a technical support ticket that includes:

  • The fact that you received the error message Error connecting to LandFX database: Automation Error
  • A screenshot of the error (if possible).
  • A description of the action you attempted within AutoCAD right before you saw the error (i.e., which of our tools you attempted to use).
  • The type of data your office is supposed to be using (Cloud or Local). If you're on Cloud, please inform us whether you received the 'ODBC'@ error mentioned above.

 

 

• Error: 'Automation Error: Error decrypting data'

You may have received this error when editing a detail. The error is an indication that the system is unable to open the detail you are trying to edit. Possible reasons include:

  • The detail file could already be open. Another user in your office might have it open, or you might even have it open in another window.
  • Your account might not have permissions to open the detail file.
  • The detail could be saved in a later version of AutoCAD from what you have (for instance, if an AutoCAD 2018 user has saved the detail and you don’t have 2018).
  • The detail could be damaged or require an Audit

 

1. Open the File menu in AutoCAD and select Open. Then select the detail file you're trying to edit.

 

2. You should now receive a clearer error message, which you can then troubleshoot. You will most likely received one of the following two error messages:

Seeing a different error at this point? If so, use the search box at the top of this page to search for the exact text of that error message on our website. Odds are, we already have a solution for it!

• That File Is Open By (Name of Person in Your Office)

If you receive this message, you'll know the CAD user named in the error message has the detail open. If so, that person will need to close the detail file before you can edit it.

 

Error Opening File, DWG Must Be Recovered (or a similar error)

If you receive this message, you'll need to recover the detail file.

 

Run the RECOVER command by either:

  • Typing RECOVER in the Command line and pressing Enter, or ...
  • Selecting Drawing Utilities from the AutoCAD File menu and then selecting Recover... from the menu that opens.

 

 

You should now be able to open and edit the detail successfully.

 

 

• Automation Error. Null object ID

This error can occur when you're trying to work with a block or detail file, such as updating a detail.

 

1. Try to open the block or detail file causing the error. (If you're using our software on a Mac using Parallels, try to open the file on the Windows side.)

 

2. This error can be caused by drawing corruption. Follow our drawing cleanup steps on both the file causing the issue and the drawing where you tried to use it.

 

3. Verify that the block or detail causing the error isn't saved in a newer DWG version. For example, the error can result from an older CAD version trying to use a block saved in a newer file type. If the file is saved in a newer version, save it into a version that is compatible with the CAD version you're using.

 

 

• Error: 'Automation Error: On locked layer'

You might receive this error when attempting to place a schedule or block. If so, the current layer is locked.

 

If you receive this error, open the Layer Properties Manager and follow our steps to unlock the current layer.

 

You should now be able to place the block or schedule without seeing the error.

 

• Error: 'Automation Error: access is denied' – possibly accompanied by a 404 File not found error

Did your get this error when attempting to update our software? If so, your security software (such as Symantec or Norton) may be preventing files on your computer from updating. Try disabling your security software temporarily while updating. Once the updates have gone through, you can re-enable your security software.

 

You might see the Automation Error: Access denied message, and possibly a 404 File not found error, when placing blocks. The error occurs because the blocks are failing to download due to a connection error. The blocks can be problematic in several possible ways. Examples include:

  • Outdated Land F/X symbol blocks without the letter prefix in their file names (which we added to our default blocks a few years ago)
  • Blocks in incorrect locations

 

The file names of the problematic blocks should be listed just before or after the error message in the Command line. Take note of these file names.

 

First, try deleting the block's source file from the folder LandFX/Blocks. Then try to place the same object again. You may need to re-assign the symbol to the block before you can place it.

 

Still getting the error? You may need to create the slide (SLD) files manually in the directory that contains the blocks you attempted to download. Doing so will prevent the drawing from trying to download those files every time, which will prevent the Automation Error.

 

• Error: 'Automation Error: An invalid character was found in text context'

 

This error is the result of illegal characters in your drawing or schedule. These can include:

  • Tilde (~)
  • Number sign (#)
  • Percent (%)
  • Ampersand (&)
  • Asterisk (*)
  • Braces ({ })
  • Backslash (\)
  • Colon (:)
  • Angle brackets (< >)
  • Question mark (?)
  • Slash (/)
  • Plus sign (+)
  • Minus sign (=)
  • Pipe (|)
  • Quotation mark (")
  • Comma (,)
  • Semi0-Colon(;)

 

 

You'll need to do a bit of digging to figure out which entity has an illegal character in its name. Here's an example:

 

Near the top of the Command line, you might see something like the following:

  • [3.164] (sys-error "Automation Error. An invalid character was found in text content.rn")
  • :ERROR-BREAK.159 nil
  • [4.156] (intelligent-invoke # TEXT 4 "037")
  • [5.148] (vlax-put-property # TEXT "037”)

 

The key text to look for here is:

  • The error message itself, and
  • The number within quotation marks following #TEXT

 

Essentially, look for the Automation Error text, then look for # TEXT after it. Take note of the charactes within the quotation marks right after # TEXT (in our example: "037").

 

To find the item with the illegal character, you'll need to do a search for all items related to this value in the Command line. This search will identify which items you need to check for the illegal characters. We recommend that you:

  • Copy the whole command line and paste that text into a text file or word processing document, and then ...
  • Use the FIND command (CTRL+F on a Windows keyboard, or Command+F on a Mac keyboard) in the text file or word processing document to search for the value that came up in your Command line.

 

 

The screenshot to the right shows an example of text you might see in the Command line when encountering this error, as copied and pasted into a text file. We've used three boxes to mark the clues to the problematic item.

 

To find the item causing the error:

 

1. Verify the error message and value for the object that's causing it (middle box).

 

2. Search for the value you've identified in the Command line (top box).

 

3. Record the name of the item (such as a block or hatch) associated with that value (bottom box).

 

In this example, we've searched for 037 and found that the problematic item is the tree Acer saccharum. We know this because the name of the symbol assigned to that tree is followed by an empty set of quotation marks (the attribute value), then by a set of quotes containing the value we've searched for, which is followed directly by another number. Note that the symbol name ("05-simple~TREE-SIMP-020") contains a tilde (~) – an illegal character.

 

 

If the issue is resulting from a plant in your drawing, as in our example, the issue commonly results from editing a plant and mistakenly adding an illegal character to the Remarks or Notes field. Note that the problem is with the data in the active Land F/X project – not with the symbol block – despite the fact that the illegal character appears in the name of the block in the Command line.

 

In this case, we'd edit the plant and check for and remove illegal characters in the Remarks field in the Plant Info dialog box.

 

You might also encounter this error if you're using one of our old default Preference Sets. Specifically, the problem would lie with Schematic Irrigation categories. If so, you'll see characters that resemble the "Wingding" font in the Command line.

The main idea is to figure out which entity has the illegal character in its name, and to remove that illegal character. If you are unable to determine which entity includes the illegal character, the next step may unfortunately be to abandon the current Land F/X project. Although that option isn't ideal, it may be necessary at this point, since that project is essentially corrupt and is preventing you from working in your drawing. If you're using project templates, you may be able to simply create a new project based on a template and then assign it to this drawing. If you really can't find the illegal character, and you are able to re-create the data in the current project (such as your plant palette), it may very well be time to leave the current project behind.

 

Error: 'Automation Error: The system cannot locate the resource specified'

 

You might also see the following error message: Unable to connect to FXDatabase on this computer. Database connection confirmed to be running yet connection refused.

 

If you see this Automation Error message, a physical or software firewall is preventing CAD from functioning correctly.

 

1. Close CAD.

 

2. Follow our instructions to add AutoCAD or F/X CAD as an exception.

 

3. Reopen CAD and repeat the action that resulted in the error.

 

Still seeing the error? Move on to the next step.

 

4. Create a new AutoCAD or F/X CAD profile, or open a different existing profile. Then attempt the action that resulted in the error.

 

  • Don't see the error now? The issue was linked to the profile you were using when you saw the error. You'll need to keep using this new (or existing) profile moving forward. If necessary, you can customize this profile with your preferred settings.
  • Still seeing the error in the new (or existing) profile? Move on to the next step.

 

5. Follow our steps to tether Land F/X using your phone.

  • Don't see the error now? The problem is with your network rather than with anything related to Land F/X. Ask your IT administrator to troubleshoot your network.
  • Still seeing the error? It's time to send us a technical support ticket describing the error. Remember to send us the exact tect of the error message and let us know that you've tried all these steps.
Last modified on Oct 15, 2018

Contact

  • Land F/X

Our software tailors AutoCAD to the needs of landscape architects, irrigation designers, and other professionals. We automate your most tedious tasks and ensure accuracy, giving you more time to design.

Log in to landfx.com:

Username:

Password: