sales@landfx.com
  +1 805-541-1003

F/X CAD 2018: New Features & Removals

F/X CAD 2018 is here! Here are some of the additions and changes you can expect in the latest version of our Autodesk-authorized CAD engine. We've made some major additions (and subtractions) to the ribbons with F/X CAD 2018.

Looking for a specific tool, ribbon, or panel? You can easily search for it on this page using the CTRL+F (Windows keyboard) or Command+F (Mac keyboard) keys.

New Ribbon Buttons and Features

Land F/X Tools Added to ACAD Ribbons

We've added several Land F/X tools to the F/X CAD 2018 ACAD ribbons. Some of these tools were previously only available as Command line commands, while others are also available on the Land F/X ribbons.

 

 

F/X Area Total

Command: AreaTotal

Calculate the area of a closed polyline or polygon in your drawing.

More information >

 

 

F/X Length Total

Command: LengthTotal

Calculate the length of a linear object in your drawing.

More information >

 

 

 

 

Site Dimension Tools

More on our Site Dimension Tools >

 

 

Aligned Dimension

Command: FX_DIMALIGNED

 

Linear Dimension

Command: FX_DIMLINEAR

 

Angular Dimension

Command: FX_DIMANGULAR

 

Arc Dimension

Command: FX_DIMARC

 

Radius Dimension

Command: FX_DIMRADIUS

 

Diameter Dimension

Command: FX_DIMDIAMETER

 

Center Mark Dimension

Command: FX_DIMCENTER

 

 

 

Text Leader Tools

More on our Text Leader tools >

 

 

Text Leader Dim

Command: FX_TextLeaderDim

 

MText Leader Frame

Command: FX_TextLeaderFrame

 

Text Leader Dot

Command: FX_TextLeaderDot

 

Text Leader Tick

Command: FX_TextLeaderTick

 

 

Land F/X Leader Tools

More on our Leader tools >

 

 

Line Leader Dim

Command: FX_LineLeaderDim

 

Tick Leader

Command: FX_TickLeader

 

Line Leader Dot

Command: FX_LineLeaderDot

 

Loop Leader

Command: FX_LoopLeader

 

Line Area Leader

Command: FX_LineAreaLeader

 

Line Leader Wide

Command: FX_LineLeaderWide

 

Line Leader Big

Command: FX_LineLeaderBig

 

Arc Leader Dim

Command: FX_ArcLeaderDim

 

Arc Leader Wide

Command: FX_ArcLeaderWide

 

Arc Leader Big

Command: FX_ArcLeaderBig

 

Arc Area Leader

Command: FX_ArcAreaLeader

 

Thick Leader Tick

Command: FX_ThickLeaderTick

 

Thick Leader Dot

Command: FX_ThickLeaderDot

 

Thick Leader Wide

Command: FX_ThickLeaderWide

 

 

 

 

 

Export to Land F/X Support

Command: TECHSUPPORT

Having a problem? Click this button to send your drawing and the associated Land F/X project to our technical support team in a technical support ticket for review.

More on sending us a tech support ticket >

 

 

 

 

fxREF

Command: FXREF
Advanced tool that provides a simple, intuitive dialog box that streamlines the process of configuring DWG files as Xrefs 

More information >

 

 

 

Nuke

Command: NUKE

Drawing corruption is a major problem with DWG files. Our Nuke tool automates the drawing cleanup process, removing corruption from your drawings.

 

 

 

Manual Cleaning

Command: (none)

Some users are apprehensive about using an automated process to clean their drawings. That's fine – we also provide a list of the specific drawing cleanup steps that are automated by the Nuke tool. This button opens your Web browser to our documentation page that outlines these manual drawing cleanup steps.

 

 

 

All ByLayer

Command: SETBYLAYER

CAD best practices call for setting your drawings to ByLayer, which allows you to work within your layers more easily and efficiently. This tool automatically sets all entities in your drawing, including objects within blocks, to Color ByLayer and Linetype ByLayer. Note that this tool is also bulti into our Nuke tool.

More information >

 

 

 

 

Delete Registered Applications (DelRegApps)

Command: DELREGAPPS

This tool wipes your drawing clean of all background applications, improving drawing performance and speed – another tool that's included in Nuke.

More information >

 


 

 

Instant Purge

Command: PRG

Run a full PURGE, including nested objects, four times over. It accomplishes what you do with the PURGE command, without all the clicking.

 

 

 

 

Clean Export

Command: (none)
This tool removes AEC/Proxy data from your drawing and saves a copy in the same folder where you've originally saved that drawing, with the suffix -CLEANED.


 

 


Cleanup Help

Command: (none)

Open your Web browser to our documentation page on how to clean your drawings. We recommend completing these steps on every drawing, including all Xrefs, that you receive from a co-worker, consultant, or client.

 

 

 

 

New F/X CAD Features

 

Off-Screen Selection

This is a long-awaited, must-have feature! Now you can select objects with increased accuracy. In previous versions, only objects visible on the screen when you click the second point were actually selected. With F/X CAD 2018, you are now free to zoom in for a precise second click. All objects between those clicks will be included in that selection box.

 

New Drawing File Type

Upgrading to F/X CAD 2018 means you can receive 2018 .dwg files from consultants or clients. You can rest easy knowing you can freely access any .dwg file you’re given! Why the change? This capability improves efficiency while opening and saving several items, such as attribute objects. Land F/X uses many attributes in our smart blocks, so this feature is an especially great improvement for Land F/X users.

 

Incremental Auto-Saving

The new 2018 file type also allows you to change your auto-save process to only save the parts of the drawing that have changed. This feature is great for reducing auto-save slowdowns when working with larger, complex drawings.

 

Linetype Gap Selection

In previous versions, you couldn’t snap to the gap in a dashed line. Now you can! This is another small improvement that will make a big difference for you on a daily basis.

Removals, Moves, and Additions

Here's a list of all tools we've removed, moved, or added to the ACAD ribbons – organized by ribbon and panel.

Looking for a specific tool, ribbon, or panel? You can easily search for it on this page using the CTRL+F (Windows keyboard) or Command+F (Mac keyboard) keys.

 

 

Home Ribbon, Draw Panel

 

 

 

Removed Tools

 

Tool Name
Command
 
Reason Removed

3D Polyline

3DPOLY

 

3D Tool

Helix

HELIX

 

3D Tool

Donut

DONUT

 

3D Tool


 

 

Added Tools

 

Tool Name
Command
 

 

 

Multiline

 

 

MLINE

 

 

 

Home Ribbon, Modify Panel

 

 

 

 

Removed Tools

 

Tool Name
Command
Reason Removed

Mirror

MIRROR

Conflicts with Land F/X blocks

Rectangular Array

ARRAYRECT

Conflicts with Land F/X blocks

Path Array

ARRAYPATH

Conflicts with Land F/X blocks

Polar Array

ARRAYPOLAR

Conflicts with Land F/X blocks

Edit Spline

SPLINEEDIT

Splines not recommended

Edit Array

ARRAYEDIT

Conflicts with Land F/X blocks

 

 

 

Moved Tools

 

Tool Name
Command
 
Moved To
Change to ByLayer SETBYLAYER   Home > Layers and Manage >Cleanup
Edit Hatch HATCHEDIT   Home > Draw (With Hatch Tools)

Delete Duplicate Objects

OVERKILL

 

To Manage > Cleanup

Bring to Front

DRAWORDER

 

To Quick Access Toolbar

Send to Back

DRAWORDER

 

To Quick Access Toolbar

Bring Above Objects

DRAWORDER

 

To Quick Access Toolbar

Send Under Objects

DRAWORDER

 

To Quick Access Toolbar

Bring Text to Front

TEXTTOFRONT

 

To Quick Access Toolbar

Bring Dimensions to Front

TEXTTOFRONT

 

To Quick Access Toolbar

Bring Leaders to Front

TEXTTOFRONT

 

To Quick Access Toolbar

Bring All Annotations to Front

TEXTTOFRONT

 

To Quick Access Toolbar

Send Hatches to Back

HATCHTOBACK

 

To Quick Access Toolbar

       

 

 

 

Added Tools

 

Tool Name
Command
 

 

 

Move/Copy/Rotate

 

 

MOCORO

 

 

 

Home Ribbon, Annotate Panel (Removed)

We've removed this panel, replacing some tools it previously included and moving others to new locations.

 

 

Removed/Replaced Tools

 

 

Tool Name
Command
 
Replaced With
 

Dimension

DIM

 

Annotation > Dimension

 

Linear Dimension

DIMLINEAR

 

Annotation > Dimension

 

Aligned Dimension

DIMALIGNED

 

Annotation > Dimension

 

Angular Dimension

DIMANGULAR

 

Annotation > Dimension

 

Arc Length Dimension

DIMARC

 

Annotation > Dimension

 

Radius Dimension

DIMRADIUS

 

Annotation > Dimension

 

Diameter Dimension

DIMDIAMETER

 

Annotation > Dimension

 

Multileader

MLEADER

 

Annotation > Leaders

 

Table

TABLE

 

 Land F/X Schedules

 

 

 

Moved Tools

 

 

Tool Name
Command
 
Moved To
 

Multiline Text

MTEXT

 

Annotate > Text

 

Single Line Text

TEXT

 

Annotate > Text

 

Ordinate

DIMORDINATE

 

Annotate > Dimension

 

Jogged

DIMJOGGED

 

Annotate > Dimension

 

Add Leader

MLEADEREDIT

 

Annotate > Leaders

 

Remove Leader

MLEADEREDIT

 

Annotate > Leaders

 

Align Multileader

MLEADERALIGN

 

Annotate > Leaders

 

Collect Multileader

MLEADERCOLLECT

 

Annotate > Leaders

 

Text Style

STYLE

 

Manage > Styles

 

Dimension Style

DIMSTYLE

 

Manage > Styles

 

Multileader Style

MLEADERSTYLE

 

Manage > Styles

 

Table Style

TABLESTYLE

 

Manage > Styles

 

 

 

 

Home Ribbon, Layers Panel

 

Removed Tools

 

Tool Name
Command
Reason Removed
Layer State Control Box (none) Space/Low Use
Locked Layer Fading LAYLOCKFADECTL Space/Low Use

 

 

Moved Tools

 

Tool Name
Command
Moved To
Layer Control Box (none) Quick Access Toolbar

 

 

Added Tools

 

Tool Name
Command
 

 

 

List Xref/Block Properties

 

 

 

 

XLIST

 

 

 

 

Change to ByLayer SETBYLAYER

 

 

 

Home Ribbon, Block Panel (Removed)

We've removed this panel, eliminating some tools it previously included and moving others to new locations.

 
 

Removed Tools

 

Tool Name
Command
Reason Removed

Syncronize Attributes

ATTSYNC

Space/Low Use

Retain Attribute Display

ATTDISP

Space/Low Use

Display All Attributes

ATTDISP

Space/Low Use

Hide All Attributes

ATTDISP

Space/Low Use

Set Base Point

SETBASE

Space/Low Use

 

 

 

Moved Tools

 

Tool Name
Command
Moved To

Insert Block

INSERT

Insert > Block

Create Block

BLOCK

Insert > Block Definition

Block Editor

BEDIT

Insert > Block Definition

Edit Single Attribute

EATTEDIT

Insert > Block

Edit Multiple Attributes

-ATTEDIT

Insert > Block

Define Attributes

ATTDEF

Insert > Block Definition

Block Attribute Manager

BATTMAN

Insert > Block Definition

 

 

 

Home Ribbon, Properties Panel

 

 

 

Removed Tools

Tool Name
Command
Reason Removed

Ribbon Combo Box – Plot Style

(none)

Space/Low Use

Transparency Method

CETRANSPARENCY

Space/Low Use

Trasparency Slider

(none)

Space/Low Use

List

LIST

Space/Low Use


 

 

Added Tools

 

Tool Name
Command
 
Properties Palette PROPERTIES

 

 

 

Home Ribbon, Groups Panel (Removed)

We've removed this panel and eliminated all tools it previously included.

 
 
Tool Name
Command
Reason Removed

Group

GROUP

Space/Low Use

Ungroup

UNGROUP

Space/Low Use

Group Edit

GROUPEDIT

Space/Low Use

Group Selection On/Off

PICKSTYLE

Space/Low Use

Group Manager

CLASSICGROUP

Space/Low Use

Group Bound Box On/Off

GROUPDISPLAYMODE

Space/Low Use

 

 

Home Ribbon, Utilities Panel

 

 

Removed Tools

 

Tool Name
Command
Reason Removed
Volume

MEASUREGEOM

3D Tool

ID Point ID

 

Space/Low Use

Point Style PTYPE

 

Space/Low Use

 

 

 

Added Tools

 

 

Tool Name
Command
 

Area Total

 

 

 

Length Total

AreaTotal (Land F/X Tool)

 

 

 

LengthTotal (Land F/X Tool)

 

 

 

Home Ribbon, Clipboard Panel

 

 

 

Added Tools

 

Tool Name
Command
 
Copy with Base Point COPYBASE

 

 

 

Home Ribbon, View Panel (Removed)

We've removed this panel, eliminating both tools it previously included.

 

 

Removed Tools

 

Tool Name
Command
Reason Removed

Base View from Model Space

(none)

Space/Low Use

Base View from File

(none)

Space/Low Use

 

 

 

Insert Ribbon, Block Panel

No changes

 

 

 

Insert Ribbon, Block Definition Panel

 

 

 

Removed Tools

 

Tool Name
Command
Reason Removed

Set Base Point

BASE

Space/Low Use

Synchronize

ATT

Space/Low Use


 

 

 

Insert Ribbon, Reference Panel

 

 

Removed Tools

 

 

Tool Name
Command
Reason Removed

Frame Settings

FRAME

Space/Low Use

Xref Fading

XDWGFADECTL

Space/Low Use

Xref Fading Slider

(none)

Space/Low Use

Underlay OSNAP Settings

UOSNAP

Space/Low Use

Underlay Layers

ULAYERS

Space/Low Use


 

 

Added Tools

 

Tool Name
Command
 

External Reference Manager

 

XREF

 

 

 

fxREF

 

 

Attach Xref

 

FXREF (Land F/X tool)

 

 

XATTACH

 

 

 

Attach Image

 

IMAGE

 

 

 

Import PDF

 

Attach PDF

 

Import DGN

 

Attach DGN

 

Import

 

Recognize SHX TEXT

 

Recognition Settings

 

Combine Text

PDFIMPORT

 

PDFATTACH

 

DGNIMPORT

 

DGNATTACH

 

IMPORT

 

PDFSHXTEXT

 

PDFSHX TEXT

 

TXT2MTXT

 

Delete Clip

 

XCLIP

 

 

 

Open Xref

 

 

Xref and Block, Save Reference Edits

 

(none)

 

 

REFCLOSE

 

 

 

 

 

 

Insert Ribbon, Point Cloud Panel (Removed)

We've removed this panel, eliminating both tools it previously included.

 
 

Removed Tools

 

Tool Name
Command
Reason Removed

Autodesk ReCap

RECAP

3D Tool

Point Cloud Attach

POINTCLOUDATTACH

3D Tool

 

 

 

Insert Ribbon, Import Panel (Removed)

We've removed this panel, eliminating one tool it previously included and moving others to new locations.

 
 

Removed Tools

 

Tool Name
Command
Reason Removed
Import FBX FBXIMPORT Space/Low Use

 

 

Moved Tools

 

Tool Name
Command
Moved To

Import PDF

PDFIMPORT

Insert > Reference

Import DGN

DGNIMPORT

Insert > Reference

Import

IMPORT

Insert > Reference

 

 

Insert Ribbon, Data Panel (Removed)

 

We've removed this panel, eliminating the single tool it previously included.

 
 
Tool Name
Command
Reason Removed
Hyperlink HYPERLINK Space/Low Use

 

 

Insert Ribbon, Linking & Extraction Panel (Removed)

 

We've removed this panel, eliminating all tools it previously included.

 

Removed Tools

 

Tool Name
Command
Reason Removed

Data Link

DATALINK

Space/Low Use

Download from Source

DATALINKUPDATE

Space/Low Use

Upload to Source

DATALINKUPDATE_W

Space/Low Use

Data Extraction

DATAEXTRACTION

Space/Low Use

 

 

 

Insert Ribbon, Location Panel

 

 

 

Added Tools

 

Tool Name
Command
 

 

Reorient Marker

 

Remove Location

 

GEOREORIENTMARKER

 

GEOREMOVE

 

 

Insert Ribbon, Content Panel

 

We've removed this panel, eliminating both tools it previously included.

 

Removed Tools

 

Tool Name
Command
Reason Removed
Design Center ADCENTER Space/Low Use
Autodesk Seek SEEK Space/Low Use

 

 

Annotate Ribbon, Text Panel

 

 

Removed Tools

 

Tool Name
Command
Reason Removed
Annotation Text Height TEXTSIZE Space/Low Use

 

 

Added Tools

 

Tool Name
Command
 

Text Manager (F/X Text)

 

 

Arc-Aligned Text

FX_Fonts (Land F/X Tool)

 

ARCTEXT

 

 

 

 

Tool Name
Command
 

Text Mask

 

Unmask Text

 

Text Fit

 

Rotate Text

 

Automatic Text Numbering

 

Explode Attributes to Text

 

Text Style

TEXTMASK

 

UNMASKTEXT

 

TEXTFIT

 

TORIENT

 

TCOUNT

 

BURST

 

STYLE

 

 

 

Annotate Ribbon, Dimensions Panel

 

Removed Tools

 

 

Tool Name
Command
Reason Removed

Aligned Dimension

DIMALIGNED

Replaced with Land F/X Version

Linear Dimension

DIMLINEAR

Replaced with Land F/X Version

Angular Dimension

DIMANGULAR

Replaced with Land F/X Version

Arc Dimension

DIMARC

Replaced with Land F/X Version

Radius Dimension

DIMRADIUS

Replaced with Land F/X Version

Diameter Dimension

DIMDIAMETER

Replaced with Land F/X Version

Center Mark Dimension

DIMCENTER

Replaced with Land F/X Version

Continue

DIMCONTINUE

Replaced with Land F/X Version

Baseline

DIMBASELINE

Replaced with Land F/X Version

Tolerance

TOLERANCE

Space/Low Use

Dimension Style Control Box

(none)

Space/Low Use

Dim Style Override Control Box

(none)

Space/Low Use

 

 

 

Added Tools

 

Tool Name
Command
 

Aligned Dimension

 

Linear Dimension

 

Angular Dimension

 

Arc Dimension

 

Radius Dimension

 

Diameter Dimension

 

Center Mark Dimension

FX_DIMALIGNED (Land F/X Tool)

 

FX_DIMLINEAR (Land F/X Tool)

 

FX_DIMANGULAR (Land F/X Tool)

 

FX_DIMARC (Land F/X Tool)

 
FX_DIMRADIUS (Land F/X Tool)

 

FX_DIMDIAMETER (Land F/X Tool)

 

FX_DIMCENTER (Land F/X Tool)

 

 

 

Annotate Ribbon, Centerlines Panel

 

No changes

 

 

 

Annotate Ribbon, Leaders Panel

 

 

 

Removed Tools

 

Tool Name
Command
Reason Removed

Multileader Style Control Box

(none)

Space/Low Use

 

 

 

Added Tools

 

 

Tool Name
Command
 

Text Leader Dim

 

MText Leader Frame

 

Text Leader Dot

 

Text Leader Tick

FX_TextLeaderDim (Land F/X Tool)

 

FX_TextLeaderFrame (Land F/X Tool)

 

FX_TextLeaderDot (Land F/X Tool)

 

FX_TextLeaderTick (Land F/X Tool)

 

 

 

 

Tool Name
Command
 

Line Leader Dim

 

Tick Leader

 

Line Leader Dot

 

Loop Leader

 

Line Area Leader

 

Line Leader Wide

 

Line Leader Big

 

Arc Leader Dim

 

Arc Leader Wide

 

Arc Leader Big

 

Arc Area Leader

 

Thick Leader Tick

 

Thick Leader Dot

 

Thick Leader Wide

FX_LineLeaderDim (Land F/X Tool)

 

FX_TickLeader (Land F/X Tool)

 

FX_LineLeaderDot (Land F/X Tool)

 

FX_LoopLeader (Land F/X Tool)

 

FX_LineAreaLeader (Land F/X Tool)

 

FX_LineLeaderWide (Land F/X Tool)

 

FX_LineLeaderBig (Land F/X Tool)

 

FX_ArcLeaderDim (Land F/X Tool)

 

FX_ArcLeaderWide (Land F/X Tool)

 

FX_ArcLeaderBig (Land F/X Tool)

 

FX_ArcAreaLeader (Land F/X Tool)

 

FX_ThickLeaderTick (Land F/X Tool)

 

FX_ThickLeaderDot (Land F/X Tool)

 

FX_ThickLeaderWide (Land F/X Tool)

 

 

 

Annotate Ribbon, Tables Panel

We've removed this panel, eliminating all tools it previously included.

 

Removed Tools

 

Tool Name
Command
Reason Removed

Table

TABLE

Replaced with Land F/X Schedules

Table Style Control Box

(none)

Replaced with Land F/X Schedules

Data Link

DATALINK

Space/Low Use

Download from Source

DATALINKUPDATE

Space/Low Use

Upload to Source

DATALINKUPDATE_W

Space/Low Use

Data Extraction

DATAEXTRACTION

Space/Low Use

 

 

 

Annotate Ribbon, Markup Panel

We've removed this panel, moving all tools it previously included to new locations.

 

Moved Tools

 

Tool Name
Command
Moved To

Wipeout

WIPEOUT

Home > Draw

Rectangular Revision Cloud

REVCLOUD

Home > Draw

Polygonal Revision Cloud

REVCLOUD

Home > Draw

Freehand Revision Cloud

REVCLOUD

Home > Draw

 

 

 

Annotate Ribbon, Annotation Scaling Panel

No changes

 

 

 

Annotate Ribbon, Parametric Panel (Removed)

We've removed this entire ribbon, eliminating all panels it previously included.

 

Removed Panels & Tools

 

Geometric Panel (Removed)

 

Tool Name
Command
Reason Removed

Auto Constrain

AUTOCONSTRAIN

Parametrics not included in F/X CAD

Coincident Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Colinear Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Concentric Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Fix Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Parallel Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Perpendicular Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Horizontal Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Vertical Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Tangent Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Smooth Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Symmetric Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Equal Geometric Constraints

GEOMCONSTRAINT

Parametrics not included in F/X CAD

Show/Hide Geometric Constraints

CONSTRAINTBAR

Parametrics not included in F/X CAD

Show All Geometric Constraints

CONSTRAINTBAR

Parametrics not included in F/X CAD

Hide All Geometric Constraints

CONSTRAINTBAR

Parametrics not included in F/X CAD

 

 

 

Dimensional Panel (Removed)

 

Tool Name
Command
Reason Removed

Linear Dimensional Constraint

DCLINEAR

Parametrics not included in F/X CAD

Horizontal Dimensional Constraint

DCHORIZONTAL

Parametrics not included in F/X CAD

Vertical Dimensional Constraint

DCVERTICAL

Parametrics not included in F/X CAD

Aligned Dimensional Constraint

DIMCONSTRAINT

Parametrics not included in F/X CAD

Radius Dimensional Constraint

DIMCONSTRAINT

Parametrics not included in F/X CAD

Diameter Dimensional Constraint

DIMCONSTRAINT

Parametrics not included in F/X CAD

Angular Dimensional Constraint

DIMCONSTRAINT

Parametrics not included in F/X CAD

Convert Dimensional Constraint

DIMCONSTRAINT

Parametrics not included in F/X CAD

Show Dynamic Constraints

DCDISPLAY

Parametrics not included in F/X CAD

Show All Dynamic Constraints

DCDISPLAY

Parametrics not included in F/X CAD

Hide All Dynamic Constraints

DCDISPLAY

Parametrics not included in F/X CAD

Dynamic Constraint Mode

(none)

Parametrics not included in F/X CAD

Annotational Constraint Mode

(none)

Parametrics not included in F/X CAD

 

 

 

Manage Panel (Removed)

 

Tool Name
Command
Reason Removed

Delete Constraints

DELCONSTRAINT

Parametrics not included in F/X CAD

Parameters Manager

(none)

Parametrics not included in F/X CAD

 

 

 

View Ribbon, Viewport Tools Panel (Removed)

We've removed this panel, eliminating all tools it previously contained.

 

Tool Name
Command
Reason Removed

UCS Icon

UCSICON

Space/Low Use

View Cube

NAVVCUBE

Space/Low Use

Navigation Bar

NAVBAR

Space/Low Use

Show Motion

NAVSMOTION

Space/Low Use

 

 

 

View Ribbon, Model and Layout Viewports Panel

 

 

 

Removed Tools

 

Tool Name
Command
Reason Removed

Named

VPORTS

Space/Low Use

Join Viewports

VPORTS

Space/Low Use

Restore Viewports

VPORTS

Space/Low Use

 

 

Added Tools

 

Tool Name
Command
 

Rectangular Viewport

 

Polygonal Viewport

 

Viewport Wizard

 

Lock Viewport

 

Unlock Viewport

 

Viewport Clip

-VPORTS

 

-VPORTS

 

VPORTS

 

-VPORTS

 

-VPORTS

 

VPCLIP

 

 

 

 

 

View Ribbon, Palettes Panel 

 

 

 

 

Removed Tools

 

Tool Name
Command
Reason Removed

Tool Palettes

TOOLPALETTES

Space/Low Use

Quick Calculator

QUICKCALC

Space/Low Use

Markup Set Manager

MARKUP

Space/Low Use

Design Center

ADCENTER

Space/Low Use

 

 

 

View Ribbon, Interface Panel

 

 

No changes

 

 

Manage Ribbon, Action Recorder Panel (Removed)

We've removed this panel, eliminating all tools it previously included.

 

Removed Tools

 

Tool Name
Command
Reason Removed

Record

ACTRECORD

Space/Low Use

Insert Message

ACTRECORD

Space/Low Use

Insert Base Point

ACTRECORD

Space/Low Use

Pause for User Input

ACTRECORD

Space/Low Use

Play

ACTRECORD

Space/Low Use

Preference

ACTRECORD

Space/Low Use

Manage Action Macros

ACTRECORD

Space/Low Use

Available Action Macro

ACTRECORD

Space/Low Use

Action Tree

ACTRECORD

Space/Low Use

 

 

 

Manage Ribbon, Customization Panel

 

 

Removed Tools

 

Tool Name
Command
Reason Removed
Tool Palettes CUSTOMIZE Space/Low Use

 

 

 

Added Tools

 

Tool Name
Command
Reason Removed

 

Options

 

Command Aliases Editor

 

OPTIONS

 

ALIASEDIT

 

 

 

Manage Ribbon, Applications Panel (Removed)

We'ved removed this panel, eliminating all tools it previously contained.

 

Tool Name
Command
Reason Removed

Load Application

APPLOAD

3rd Party Apps/Scripts Not permitted on F/X CAD

Run Script

SCRIPT

3rd Party Apps/Scripts Not permitted on F/X CAD

Visual Basic Editor

VBAIDE

3rd Party Apps/Scripts Not permitted on F/X CAD

Visual LISP Editor

VLISP

3rd Party Apps/Scripts Not permitted on F/X CAD

Run BA Macro

VBARUN

3rd Party Apps/Scripts Not permitted on F/X CAD

Load Project

VBALOAD

3rd Party Apps/Scripts Not permitted on F/X CAD

VBA Manager

VBAMAN

3rd Party Apps/Scripts Not permitted on F/X CAD

 

 

 

Manage Ribbon, CAD Standards Panel

No changes

 

 

 

Manage Ribbon, Styles Panel

 

We've added this panel to the Manage ribbon, providing several tools for customizing the text, dimension, leader, table, and unit styles in your drawings.

 

 

Added Tools

 

Tool Name
Command
 

Text Style

 

Dimension Style

 

Multileader Style

 

Table Style

 

Units

STYLE

 

DIMSTYLE

 

MLEADERSTYLE

 

TABLESTYLE

 

UNITS

 

 

 

Manage Ribbon, Cleanup Panel

 

 

We've added this panel to the Manage ribbon, providing several tools for cleaning your drawings, ridding them of corruption.

 

 

Added Tools

 
 
Tool Name
Command
 

NUKE

 

Manual Cleaning

 

Thaw All

 

All On

 

Delete Duplicates

 

All ByLayer

 

Set to ByLayer

 

Delete Registered Applications

 

Audit

 

Instant Purge

 

Purge

 

Clean Export

 

Cleanup Help

NUKE (Land F/X Tool)

 

(None) (Land F/X Tool)

 

LAYTHW

 

LAYON

 

OVERKILL

 

GOBYLAYER (Land F/X Tool)

 

SETBYLAYER 

 

DELREGAPPS (Land F/X Tool)

 

AUDIT

 

PRG (Land F/X Tool)

 

PURGE

 

(None) (Land F/X Tool)

 

(None) (Land F/X Tool)

 

 

 

Output Ribbon, Plot Panel

 

 

Removed Tools

 

Tool Name
Command
Reason Removed
View Details VIEWPLOTDETAILS Space/Low Use
Plotter Manager PLOTTERMANAGER Space/Low Use

 

 

 

Added Tools

Tool Name
Command
 
Plot Style Manager STYLESMANAGER

 

 

Output Ribbon, Export Panel

 

Removed Tools

 

 

Tool Name
Command
Reason Removed

Export Drop-Down

(none)

Space/Low Use

Ribbon Combo Box – EplotExport

(none)

Space/Low Use

Export Window

(none)

Space/Low Use

Page Setup

(none)

Space/Low Use

Preview

EXPORTSETTINGS

Space/Low Use

Export to DWF Options

(none)

Space/Low Use

Export to PDF Options

(none)

Space/Low Use

 

 

 

Added Tools

 

Tool Name
Command
 

eTransmit

 

Export Layout to Model

 

Export to Land F/X Support

ETRANSMIT

 

EXPORTLAYOUT

 

TECHSUPPORT (Land F/X Tool)

 

 

A360 Ribbon (Removed)

We've removed this entire ribbon, elimintaing all panels and tools it previously included.

 

Removed Panels & Tools

 

Share Panel (Removed) 

 

Tool Name
Command
Reason Removed
Share Design View ONLINEDESIGNSHARE A360 not included in F/X CAD 2018
Share Document ONLINESHARE A360 not included in F/X CAD 2018

 

 

Online Files Panel (Removed)

 

Tooll Name
Command
Reason Removed
Open Local Sync Folder ONLINEOPENFOLDER A360 not included in F/X CAD 2018
Open A360 Drive ONLINEDOCS A360 not included in F/X CAD 2018

 

 

Settings Sync Panel (Removed)

 

Tool Name
Command
Reason Removed
Sync My Settings ONLINESYNC A360 not included in F/X CAD 2018
Choose Settings ONLINESYNCSETTINGS A360 not included in F/X CAD 2018

 

 

Express Tools Ribbon, Blocks Panel

 

Removed Tools

 

Tool Name
Command
Reason Removed

Replace Block with Another Block

BLOCKREPLACE

Space/Low Use

Import Attribute Information

ATTIN

Space/Low Use

Export Attribute Information

ATTOUT

Space/Low Use

Convert Block to Xref

BLOCKTOXREF

Space/Low Use

Extend to Nested Objects

BEXTEND

Space/Low Use

Trim to Nested Objects

BTRIM

Space/Low Use

 

 

Moved Tools

 

Tool Name
Command
Moved To

Explode Attributes to Text

BURST

Annotate > Text

List Xref/Block Properties

XLIST

Home > Layers

Copy Nested Objects

NCOPY

Home > Modify

 

 

Express Tools Ribbon, Text Panel

 

Removed Tools

 

Tool Name
Command
Reason Removed

Explode Text

TXTEXP

Space/Low Use

Enclose Text with Object

TCIRCLE

Space/Low Use

Remote Text

RTEXT

Space/Low Use

 

 

Moved Tools

 

Tool Name
Command
Moved To

Arc-Aligned Text

ARCTEXT

Annotate > Text

Change Text Case

TCASE

Annotate > Text

Rotate Text

TORIENT

Annotate > Text

Text Fit

TEXTFIT

Annotate > Text

Justify Text

TJUST

Annotate > Text

Convert Text to MText

TXT2MTXT

Annotate > Text

Automatic Text Numbering

TCOUNT

Annotate > Text

Text Mask

TEXTMASK

Annotate > Text

Unmask Text

TEXTUNMASK

Annotate > Text

 

 

Express Tools Ribbon, Modify Panel

 

Removed Tools

 

Tool Name
Command
Reason Removed

Multiple Object Stretch

MSTRETCH

Space/Low Use

Flatten Objects

FLATTEN

Space/Low Use

Extended Clip

CLIPIT

Space/Low Use

Extended Offset

EXOFFSET

Space/Low Use

Convert Shape to Block

SHP2BLK

Space/Low Use

 

 

Moved Tools

 

Tool Name
Command
Moved To
Move/Copy/Rotate MOCORO Home > Modify

 

 

Express Tools Ribbon, Layout Panel

 

Removed Tools

 

Tool Name
Command
Reason Removed

Align Space

ALIGNSPACE

Space/Low Use

Synchronize Viewports

VPSYNC

Space/Low Use

Merge Layout

LAYOUTMERGE

Space/Low Use

List Viewport Scale

VPSCALE

Space/Low Use

 

 

Express Tools Ribbon, Draw Menu

 

Removed Tools

 

Tool Name
Command
Reason Removed
Break-Line Symbol BREAKLINE Space/Low Use
Super Hatch SUPERHATCH Land F/X does not recommend or support Super Hatch

 

 

Express Ribbon, Dimension Menu

 

Removed Tools

 

Tool Name
Command
Reason Removed

Attach Leader to Annotation

QLATTACH

Space/Low Use

Global Attach Leader to Annotation

QLATTACHSET

Space/Low Use

Detach Leaders from Annotation

QLDETACHSET

Space/Low Use

Reset Dim Text Value

DIMREASSOC

Space/Low Use

Dimstyle Import

DIMIM

Space/Low Use

Dimstyle Export

DIMEX

Space/Low Use

 

 

Express Tools Ribbon, Tools Panel

 

Removed Tools

 

Tool Name
Command
Reason Removed

Attach Xdata

XDATA

Space/Low Use

List Object Xdata

XDLIST

Space/Low Use

System Variable Editor

SYSVDLG

Space/Low Use

Extended Plan

EXPLAN

Space/Low Use

Make Linetype

MKLTYPE

Space/Low Use

Make Shape

MKSHAPE

Space/Low Use

 

 

Moved Tools

 

Tool Name
Command
Moved To
Command Alias Editor ALIASEDIT Manage > Customization

 

 

Express Tools Ribbon, Web Panel

 

Removed Tools

 

Tool Name
Command
Reason Removed
Show URLs SHOWURLS Space/Low Use
Change URLs CHURLS Space/Low Use
Find and Replace URLs REPURLS Space/Low Use

New Keyboard Shortcuts

F/X CAD 2018 also comes with several new two-character keyboard shortcuts. More information >

Reorganizing the Ribbons & Quick Access Toolbar

Don't like our changes to the ribbons or the Quick Access Toolbar? No problem! You can add, remove, or move tool buttons to your liking.

How Do I Get the F/X CAD 2018 Tools and Ribbons?

All the tools described on this page are available with F/X CAD 2018. (Note: F/X CAD requires a license of Design F/X, Planting F/X, or Irrigation F/X).

 

If you're an existing Land F/X customer who is using our software with AutoCAD, you can download the F/X CAD 2018 CUIX file (linked below) to try out these features from within your existing AutoCAD installation.

 

First, download this file:

 

 

Once you've downloaded the CUIX file, double-click it to unzip it. Then follow our instructions to locate and replace (restore) the acad.cuix file.

Reverting to the Default AutoCAD or F/X CAD Ribbons

Made some changes to the ribbons and don't like what you see? No problem. You can easily download the default F/X CAD 2018 CUIX file (linked below).

 

Or do you want to abandon all of our ribbon updates and go back to the default AutoCAD ribbon? Download the CUIX file for AutoCAD 2018 (linked below).

 

Double-click the downloaded CUIX file to unzip it. Then follow our steps to locate and replace (restore) your existing CUIX file.

Last modified on Jan 11, 2019

Contact

  • Land F/X

Our software tailors AutoCAD to the needs of landscape architects, irrigation designers, and other professionals. We automate your most tedious tasks and ensure accuracy, giving you more time to design.

Log in to landfx.com:

Username:

Password: