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  1. Knowledge Base
  2. Installation Troubleshooting & Errors
  3. Installing F/X CAD: Info & Troubleshooting
  4. Installation Incomplete. Some Products Failed to Install. F/X CAD 20xx Did Not Install (Error Code: 1603)

.NET 4.5 is Not Installed. AutoCAD Cannot be Installed Without This Component. (Installing F/X CAD or AutoCAD)

Issue

When installing an Autodesk product (such as F/X CAD or AutoCAD), you saw an error message similar to the following:

.NET 4.5 is not installed. AutoCAD 20XX cannot be installed without this component. See your system administrator for more information.

.NET 4.5 is not installed error message

 

 

 

Cause

A problem with the Windows .NET Framework is preventing your Autodesk product from installing correctly.

 

 

Solution

You can correct this issue by temporarily changing the Windows .NET Framework currently installed on your computer.

 

 

Step 1: Change Your Version of .NET to 4.5

 

1. Press the WINDOWS and R keys (Windows keyboard) or Command and R keys (Mac keyboard) to open the Run window.

 

 

 

2. Type REGEDIT, and click OK.

Typing Regedit in the Run dialog box, Open field

 

 

 

Navigating to the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client

3. Navigate to and select the following Registry Key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client

 

 

 

4. In the right pane, note the value of the Version key in the Data column. (In our example, the Version value is 4.5.50938.)

 

Then double-click the Version file.

 

Running the Version file

Make a note of the current version at this point (in our example, the version is 4.5.50938). You'll need to restore this version at the end of these steps.

 

 

 

5. In the Edit String dialog box, change the Value data to 4.5.

Changing the Value data to 4.5 in the Edit String dialog box

 

 

 

Step 2: Install AutoCAD or F/X CAD

Close the Registry Editor, and install your version of F/X CAD or AutoCAD.

 

 

 

Changing .NET version back to version 4.5.50938

7. Once finished, go back into Regedit, and repeat steps 4 and 5 above, changing the .NET version back to its original value. In our example, we'll change it back to version 4.5.50938.

 

For further information, please see the official Autodesk solution to this issue.

Can't change the reg key because you're not the administrator?

 

You might be receiving an Access denied or Error while deleting key message when trying to change reg keys. Both of these messages are the result of not having administrator status.

 

To resolve this issue:

 

1. Select a key you want to edit.

 

2. Right-click that same key.

 

 

3. Select Permissions from the menu that opens.

Permissions option in menu opened by right-clicking a key

 

 

 

Setting permission to Full Control

4. Select the System option from the Group or user names. Select the Allow option next to Full Control. Then click Apply.

 

5. Set Full Control to Allow in the same way for the System option.

 

You should now be able to edit reg keys.

Contact

  • Land F/X
  • PMB 351
    3940 Broad St. STE 7
    San Luis Obispo, CA 93401
  • +1 805-541-1003
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