Land F/X Cannot Connect to MySQL
sales@landfx.com
+1 805-541-1003

Land F/X Cannot Connect to MySQL

Issue

You saw the following error message:

Land F/X cannot connect to MySQL.

 

 

Cause

Land F/X is unable to reach your database server. Your MySQL service may not be running, or a firewall may be blocking access.

.

 

 

Solution

The following steps need to be completed from the computer that is currently functioning as your Land F/X database server.

Step 1: Check whether MySQL is stopped

The menus and folders pictured below may look different on your computer, depending on your Windows operating system.

 

 

 

Press the Windows + R keys (Windows keyboard) or Command + R keys (Mac keyboard) to open the Run dialog box.

 

Type services.msc in the text field, and click OK.

Typing services.msc in the Run dialog box

 

 

 

In the Services screen, scroll down to the MySQL entry. Click this entry to select it.

 

If you do not see the word Started sfter MySQL, you'll need to start the MySQL service.

 

Services screen, MySQL entry not listed as Started

Don't see MySQL in the Services list? Move on to Step 4.

 

 

Step 2: Start MySQL >(if necessary)

Highlight MySQL, and click the link to Start the service.

 

Services screen, MySQL service, Start the Service button

This link may appear in a different location on your screen than pictured above.

 

In most cases, starting MySQL as described above will repair the issue. However, you may also need to configure MySQL to start automatically (Step 3).

 

 

Step 3: Configure MySQL to start automatically

Double-click the entry for MySQL to view its properties. The MySQL Properties dialog box will open.

 

 

 

Verify the following settings:
  • Startup type should be set to Automatic. If not, select Automatic using the pull-down menu.

 

 

  • Service Status should read "Started." If not, click Start.

 

 

 

Click OK when finished.

MySQL Properties dialog box, Startup Type set to Automatic and Service Status set to Started

 

 

 

Step 4: What to do if you don't see "MySQL" in the services list

You may not see an entry for MySQL in the services list for a few specific reasons:

  • Your LandFX folder may be on your office server, and you may be attempting these steps from another computer. If your LandFX folder is on a server, you'll need to perform steps 1 through 3 (outlined above) on your server. You may need your system administrator's help in completing these steps from the server.

 

  • Your LandFX folder and its contents may have been moved or copied from one computer to another. If so, your MySQL database may not have been moved over. To address this issue, you'll need to download and install MySQL.

 

 

Still unable to connect? Move on to Step 5.

 

 

 

Step 5: Troubleshoot your ODBC connection

Follow our steps to troubleshoot your ODBC connection.

 

Still unable to connect? Move on to Step 6.

 

 

 

Step 6: Add a firewall eException

Complete this step from the workstation where the issue is occurring.

A firewall may be preventing you from accessing the F/X Server. Follow our steps to create a firewall exception for MySQL and Land F/X.

Last modified on May 11, 2022

Contact

  • Land F/X

Our software tailors AutoCAD® to the needs of landscape architects, irrigation designers, and other professionals. We automate your most tedious tasks and ensure accuracy, giving you more time to design.

Log in to landfx.com:

Username:

Password: