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  1. Knowledge Base
  2. Irrigation
  3. Irrigation Schedules
  4. Irrigation Schedule Not Showing Correct Remote Control Valve (RCV) Quantities

Multiple or Duplicate Pipe Instances in Irrigation Schedule

Issue

You ran an Irrigation Schedule and noticed a large list of duplicate pipe entries of the same size, as pictured to the right.

Other equipment duplicated?

Is your schedule showing multiple entries for other types of equipment with duplicate symbols and quantities? If so, here's what to do.

Irrigation Schedule showing large list of pipe entries of the same size
Lateral pipe showing as sleeves in the Irrigation Schedule

Are you seeing the wrong pipe symbol in the schedule (for example, lateral pipe showing as sleeves)?

 

If so, you're likely experiencing a past bug that changed the symbol assignment in the project/Preference data file. To address the issue, skip to Step 2: Address a possible issue with your Preference Set and project data below.

 

 

 

 

Cause

This issue can result from:

  • A bug that has caused the XML data file for your Pipe Data to replicate sizes when checking the data it was using, and/or
  • An issue with your Preference Set pipe data, as well as any project data file that originated with the problematic Preference Set

 

Solution

Step 1: Check for and address a possible XML bug.

1A. Navigate to your LandFX folder, and go to the following location: LandFX/data/xml.cache

 

 

1B. Delete all files from within that folder.

Deleting all files from the folder LandFX/data/xml.cache

 

 

1C. Restart CAD and regenerate your schedule.

 

Still seeing duplicate pipe entries in the Irrigation Schedule? If so, move on to the next step.

 

 

 

Step 2 (if necessary): Address a possible issue with your Preference Set and project data.

If you're still having the issue, your next step should be to correct the LFX (.lfx) file(s) associated with any plan where you're seeing duplicate pipes in the schedule. These fixes will take in the source LFX file outside CAD.

You'll need to make the following changes in both the Preference Set and project data files before trying to run a new schedule.

 

 

 

2A. Back up the LFX files for your Preference Set and project.

For the Preference Set:

Open any of our Preferences screens.

 

Select the correct Preference Set, then click Manage.

 

In the Manage Preference Sets dialog box, click Backup.

 

When prompted, save the LFX Preferences file to your desktop.

Backing up a Preference Set

 

 

Backing up a project data file
For the project data file:

Open your Project List.

 

Select the correct project for your plan, then click Backup.

 

Select the option to Backup to a Land F/X project.

 

Click OK, then save the file to your desktop.

 

 

 

2B. Make temporary backup copies of the LFX files.

Go to your desktop and locate the two LFX files you saved in the previous step. For safety purposes, make a backup copy of each of these files just in case something goes wrong in the editing process and you need to restore an original version of these project and Preference Set files.

 

2C. Adjust the newly downloaded LFX files.

Right-click each of the two LFX files you saved on your desktop, and open them using a text editing application such as Notepad.

 

With the text file open for each LFX file, press the CTRL + F keys to activate the Find command.

 

 

 

The term you need to search for, and what to do with that term, will depend on what you're seeing in the Irrigation Schedule, and what you should be seeing. Here are a couple of examples:

 

 

Example 1: Seeing mainline pipe in the schedule when you should be seeing another type of pipe.

 

Search for MAINPIPE.

 

Delete each section of text that contains the term MAINPIPE.

 

In this example, we would delete the entire section beginning with <projdata> and ending with </projdata> because this section contains the term MAINPIPE.

The text file may contain multiple sections that include the text MAINPIPE. To eliminate the duplicates, take care to delete all these sections.

Searching for and deleting pipe-related data in a text file

 

 Close

 

 

 

Example 2: Seeing lateral pipe show up with pipe sleeve symbols in the schedule.

 

In this case, search for the term LATPIPE.

Searching a text file for LATPIPE

 

Example showing text appearing incorrectly in a text file entry

If you see anything other than LATPIPE in the same block of text as the found LATPIPE line, remove that entire section.

 

 Close

 

 

 

 

 

Save the changes to both LFX files.

 

 

 

Restoring a project data file

Open your Project List again, then click Restore.

 

Click Import in the Restore Project dialog box.

 

Select the LFX file you just adjusted from your desktop.

 

 

 

Click OK in the Enter Project Number dialog box.

 

Then, when asked if you want to overwrite the existing project, click Yes to overwrite it.

Selecting a project number and clicking OK

 

Clicking Yes to overwrite and existing project

 

 

 

Option to click Yes to overwrite an existing Peeference Set

Repeat the step above to restore your edited Preference Set LFX file, this time clicking Yes to overwrite it.

 

 

 

Open the Irrigation Manager, then click Pipe Data to open our Pipe Data tool.

 

In the Pipe Data dialog box, click the relevant tab for the pipe type that is duplicating in the schedule. In our example, we'll click the Mainline tab. This step will allow the system to generate the defaults.

You'll need to rebuild your Pipe Data Defaults in your Irrigation Preferences and in your Pipe Data after restoring the LFX files.

Opening the Pipe Data dialog box and clicking the Mainline tab

 

 

 

Now run a new Irrigation Schedule (or regenerate the existing schedule). All pipe duplicates should now be removed.

Still seeing duplicate pipes in the schedule? Send us a technical support ticket detailing your issue and letting us know that you attempted these steps.

Contact

  • Land F/X
  • PMB 351
    3940 Broad St. STE 7
    San Luis Obispo, CA 93401
  • +1 805-541-1003
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