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  1. Knowledge Base
  2. 3D Rendering
  3. Revit Issues & Info
  4. Knowledge Base
  5. 3D Rendering
  6. Adding, Placing & Editing Plants in Revit®
  7. You Are Unable to See the Planting F/X for Revit® Plugin Plant Family Library

Planting F/X ERROR OCCURRED: Component LAFX-... Could Not Be Found (Using Our Planting for F/X Revit® Plugin)

Issue

 

You saw an error message similar to the following while using one of our plugins for Revit:

Planting F/X ERROR OCCURRED

component LAFX-TREE-CONF-XXX could not be found

Planting F/X ERROR OCCURRED: component LAFX-TREE-CONF-003 could not be found

 

 

 

Cause

This error can occur because:

  • Your Revit library path is set to a location that the plugin is ubable to write to, or
  • You are attempting to access custom content, but your installation is not connected to the library folder that contains that custom content.

 

If the file name in the error begins with LAFX- (for example, LAFX-TREE-CONF-003 as pictured above) it means your library location is set to a location where our default content can't download automatically. If the file name begins with anything other than LAFX-, the file is likely a piece of custom content that is unable to download.

 

 

 

Solution

1. Before closing the error message, note the file name it references, and verify whether or not it starts with LAFX-.

 

2. Verify that your library path is set to a writable location. Use our Set Up Your Planting F/X Library Folder for Revit documentation for information on setting a writable library path to use with our plugin for Revit. In most cases, setting your library to a correct location will resolve the error.

Did the file name referenced in the error begin with LAFX-?

In the vast majority of cases, the file name referenced in the error will have started with LAFX- – an indication that the plugin was attempting to download a piece of our default content (such as a tree file) to an incorrect library location. If so, correcting your library location will have most likely addressed the issue.

 

If the file name began with something other than LAFX- (less common), the plugin is likely attempting to access custom content (as opposed to default Land F/X ), likely meaning that your installation is not connected to the library folder housing that content.

 

We've seen this issue occur when:

  • All users in a single office set up a separate Library folder on their own local computer, or
  • An office's custom family content has not been correctly saved to all applicable Revit version year library folders

 

In these cases, you can address the issue by:

  • Creating Library folders on a shared office file location such as a shared office server, or a shared online folder like dropbox. Make sure to connect with a mapped letter drive, and that all users have read/write permissions.
  • Creating appropriate Revit year version copies in all year version Library folder. It's always best to start making custom families in your oldest used Revit version year and then either save them up manually or batch save them up with Dynamo scripts.

 

Revit® is a restricted trademark of Autodesk®.

Contact

  • Land F/X
  • PMB 351
    3940 Broad St. STE 7
    San Luis Obispo, CA 93401
  • +1 805-541-1003
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Our software tailors AutoCAD®, Revit®, and SketchUp® to the needs of landscape architects, irrigation designers, and other professionals. We automate your most tedious tasks and ensure accuracy, giving you more time to design.

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