Skip to main content
Land F/X
  • Portal
  • Products
    • Detail F/X
      • Product
      • Features
      • Trial
      • Purchase
    • Planting F/X
      • Product
      • Features
      • Trial
      • Purchase
    • Irrigation F/X
      • Product
      • Features
      • Trial
      • Purchase
    • F/X CAD
    • Plugin for Revit®
    • Plugin for SketchUp®
    • Plugin for Rhino®
    • Site & Hardscape
    • Lighting
    • Manufacturer Connection
    • Academic
    • Purchase
  • Support
    • Knowledge Base
    • Documentation
    • Submit Ticket
    • Updates
    • Forum
    • Install
  • Videos
    • Power Tips
    • Webinars
    • Podcasts
  • Who We Are
    • Contact Us
    • Careers
    • Gallery
    • News
Land F/X
  • Portal
  • Products
    • Detail F/X
      • Product
      • Features
      • Trial
      • Purchase
    • Planting F/X
      • Product
      • Features
      • Trial
      • Purchase
    • Irrigation F/X
      • Product
      • Features
      • Trial
      • Purchase
    • F/X CAD
    • Plugin for Revit®
    • Plugin for SketchUp®
    • Plugin for Rhino®
    • Site & Hardscape
    • Lighting
    • Manufacturer Connection
    • Academic
    • Purchase
  • Support
    • Knowledge Base
    • Documentation
    • Submit Ticket
    • Updates
    • Forum
    • Install
  • Videos
    • Power Tips
    • Webinars
    • Podcasts
  • Who We Are
    • Contact Us
    • Careers
    • Gallery
    • News
  1. Home
  2. Knowledge Base
  3. Site & Details
  4. Errors: Site & Details
  5. 1 Block Deleted (Placing a Detail or Other Block)

    []

    Error Querying Data: Table 'landfx.details' Doesn't Exist (Adding, Placing, or Accessing Details)

    Updated on: May 18, 2022

    Issue

     

    You saw the following AutoCAD message when trying to add, place, or otherwise access your Land F/X details:

    Error querying data: Table 'landfx.details' doesn't exist

    Error querying data: Table 'landfx.details' doesn't exist

     

     

    You may also be getting one or both of the following errors:

    • Error querying data: Automation error. Operation is not allowed when the object is closed.
    • Error executing data request: Automation Error. Operation is not allowed when the object is closed.

     

     

    Cause

    Your Detail Library has likely been moved to the wrong location.

     

     

    Solution

     

    Step 1: Verify the Detail Library Folder

     

    Open the Details Preferences, and click the ... button next to the Detail Library listing (pictured to the right).

    Details Preferences, button to open detail library

     

     

     

    Browsing to the location LandFX/Details in the Browse for Folder dialog box

    In the Browse for Folder dialog box, select the location LandFX/Details.

     

     

    Then click OK.

     

     

     

    If you see the message Do you wish to move your entire detail library to the new destination, overwriting what is there?, click No.

    Do you wish to move your entire detail library to the new destination, overwriting what is there?

     

     

     

    Your detail system should now work correctly.

     

    Still getting the error? Move on to the next step.

     

     

     

    Step 2: Revert the Detail Index File

     

    If you're still getting the error message or otherwise unable to access your details in the Detail Explorer, your detail index file may have become corrupt.

     

    1. Follow our steps to revert the detail index file (_index_.xml) to the previous restored version.

     

    2. Adjust the Scale and Rotation settings to your liking, then click OK.

    Still getting the error? Or still getting one or both of the following errors?

    • Error querying data: Automation error. Operation is not allowed when the object is closed.
    • Error executing data request: Automation Error. Operation is not allowed when the object is closed.

    If so, do the following:

    1. Restart your computer and open AutoCAD.

    2. Still getting an error? Have your IT administrator check for and resolve:

    • Issues with MySQL services on your workstation
    • Permissions to the LandFX folder and MySQL folder/database (Local Data users)
    • Malware

    Contact

    • Land F/X
    • PMB 351 3940 Broad St. STE 7
      San Luis Obispo, CA 93401
    • +1 805-541-1003
    Email Logo Facebook Logo Instagram Logo LinkedIn Logo
    Land F/X Logo

    Our software tailors AutoCAD®, Revit®, SketchUp®, and Rhino® to the needs of landscape architects, irrigation designers, and other professionals. We automate your most tedious tasks and ensure accuracy, giving you more time to design.

    • Portal
    • Products
    • Support
    • Videos
    • Who We Are