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  1. Home
  2. Knowledge Base
  3. Installation Troubleshooting & Errors
  4. MySQL
  5. Cannot Connect to Server (Local Data)

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    Cannot Connect to Server (Local Data)

    Updated on: May 08, 2026

    Issue

    You saw a Cannot connect to server message when using Land F/X with Local Data.

    Multi-User Land F/X with Local Data (MySQL) is officially deprecated.

    We've officially deprecated Local Data (MySQL) installs as of May 2026. For optimal Land F/X performance, we recommend switching to Cloud Data.

    How to switch to Cloud Data

    Learn more about Cloud Data

     

     

    Cause

    Your ODBC connection to the MySQL database is configured improperly.

    The "server" mentioned in this error message is actually your F/X Server. If you have a Single-User installation, this component will be on your computer. If your office has a computer that functions as a central server, your F/X Server will likely be on that computer.

    Want to learn more about ODBC, MySQL, and the F/X Server? See our Definitions article.

     

     

     

    Solution

    Single-User (Standalone) installations

     

    Examples of a Single-User installation include:

    • A single office computer with our software installed that is not connected to a Land F/X server on a central office server
    • An installation of our software on a home computer or laptop

     

    If you have our software installed in one of these ways, here's what to do:

     

    1. Troubleshoot your ODBC connection for a standalone installation.

     

     

    2. If you see a Connection Failed message, follow our steps to test and configure your MySQL connection.

     

     Close

     

     

    Multi-User (office server) installations

     

    Here's what to do if your office has our software installed on a central server:

     

    1. Follow our steps to troubleshoot your ODBC connection for a server installation.

     

     

    2. If you experience lag time while testing your ODBC connection, you likely have a network connection issue. Follow our steps to ping your server name.

     

     

    3. If your server responds quickly to the ping BUT your ODBC cannot connect, follow our steps to test and configure the MySQL service on the server.

     

     

    4. If the test takes more than a second to show Connection Successful, follow our steps for troubleshooting a slow connection.

     

     

    5. Go back to your workstation and troubleshoot your ODBC connection again. Still having an issue connecting to your server? Contact your IT department for help.

     

     Close

     

     

    Contact

    • Land F/X
    • PMB 351 3940 Broad St. STE 7
      San Luis Obispo, CA 93401
    • +1 805-541-1003
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    Our software tailors AutoCAD®, Revit®, SketchUp®, and Rhino® to the needs of landscape architects, irrigation designers, and other professionals. We automate your most tedious tasks and ensure accuracy, giving you more time to design.

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